Seeing files over network


#1

I am using a 1TB WD Wireless Pro and Windows 10. I am connected to the MyPassport wireless connection and when I go to the Windows network icon in windows explorer I can see the MyPassport storage icon. However when I click on this, the MYPassport web page opens, I do not see the normal windows file structure. What am I doing wrong?.
Thanks for your help


#2

Your MPWP has to be concurrently connected to your home wi-fi signal. The complete user manual tells you how. Find manual here or in your drive.


#3

Thanks, I forgot to say it was connected to my home wi-fi at the same time and I can browse OK.


#4

Then you are fine. You will not see files on web page; only on computer or on My Cloud app.

My Cloud app.


#5

OK Thanks again,
I have followed Page 29 of the user manual, as below, but when I get to the bit "The drives storage folder opens" it does not happen, all I get is the MyPassport main configuration page opening in my browser. It works OK when I plug it in via USB connection.

Devices on the same network

  1. Ensure that your device(s) are connected to your My Passport Wireless Pro/My
    Passport Wireless SSD drive or to the same wireless network as your My
    Passport Wireless Pro/My Passport Wireless SSD drive.
    The drive can act as a wireless client device on your Wi-Fi network so everyone
    on the network can access it (like a regular network attached storage device).
  2. On your computer, open the File Explorer (PC) window or Finder (Mac).
  3. Do one of the following:
    :black_small_square: Windows: In the left pane of the File Explorer window, click Network >
    MyPassport (or name you assigned) > Storage.
    :black_small_square: Mac: In the left pane of the Finder window in the SHARED section, doubleclick MyPassport (or name you assigned) > Storage.
    The drive’s Storage folder opens.
  4. Drag and drop files from network-connected devices to the drive’s Storage
    folder

#6

Call WD after weekend.


#7

Huh.

I am not sure about the manual. . . but I know that clicking on an Icon in the “storage” section of network opens the device webpage (a.k.a. the dashboard) for mycloud products. (You can see the default is “View Device webpage” by right clicking on the icon). The WD NAS drives (which run similar software) work the same way.

To access files from the file explorer;

  • if the drive shows up as a “Computer” in the network group. . .click that. My cloud products can show up in both groups. (note: MyCloud devices don’t always show up in the “Computer” group. This is a flaw in the Windows O/S)

  • In the address bar of file explorer, type the IP ADDRESS of the drive. (\192.168.0.whatever) or the DriveName (*\drivename)) ((use double slash - forum software won’t display double forward slashes. . . .if you forget the slashes, you get the Dashboard popping open in a browser window))


#8

Thanks for your reply.
I have double checked everything and the problem persists.
As per the manual I am connected to MyPassport via WiFi and connected to the Internet via MyPassport.

  1. The drive does not appear in the “Computer” group.
  2. When I put \192.168.60.1 into a window explorer window I get “Windows cannot access \192.168.60.1”
    Windows explorer still shows MyPassport (Storage) and MyPassport (Media Player) under the Network icon. But once again if you click on the MyPassport Storage Icon, you get the MYPassport dashboard.
    This is not critical, it works OK if connected via USB, just frustrating that its not a simple fix for Win 10 users.

#9

I have both an original MPW Gen1 and the SSD models. Both work perfectly, so I will tell you what I am doing right now using the SSD model so you can do same.

The MPWSSD wi-fi is connected to my router’s 5G wi-fi. It takes a couple of minutes to get a good connection. I have an iPhone connected to router 5G wi-fi playing music from MPW via WD’s My Cloud app.

At same time my Win 7 laptop sees MPW in file explorer and is playing the movie Casablanca from MPW on laptop!

It is important how you locate MPW within FILE EXPLORER; the MPW shows up in FE’s LEFT pane (not right pane) in Network section.(Don’t use Computer section). This may be the problem; you are looking in the wrong place.


#10

Mike is essentially correct.

My experience is that if a drive doesn’t show up in the “computer” section of File Explorer’s right pane; it won’t show up in the Left pane either. I experience this issue with multiple WD products (most are running similar firmware).

If you click on an icon in the “storage” section. . .you will DEFINATELY get the device web page. That is the default configured by the operating system, and you can’t change it (easily)

You should definitely be able to access the files over wifi via file explorer. It’s an important feature of the device.

Let’s do some trouble shooting. First, what wifi network is your PC logged into?

  • If you are logged into the network of your home router, you need to access the WD drive via the IP address assigned by the home router. (hint: It won’t be 192.168.60.1 by default)

  • if you are logged into the network of the MPW device, then the “Double \” 192.168.60.1 should work. (that is the default IP of the MPW router on the MPW sub-network)

  • If you are logged into the network of your home router, verify that you have enabled file sharing (I forget the exact menu wording) in setup screen on the MPW network. The default (I believe) is to NOT have your files visible to the broader network (this is important when using the drive at Starbucks, for example)


#11

I forgot to add in my instructions that if you do not see MPW when you think you should in FE, clicking on the FE window REFRESH arrow in upper right of window can make MPW appear / reappear.


#12

Thanks Guys, but I give up. I will connect using a USB connection. I have been in the IT business a long time and thought these problems had disappeared long ago. But apparently not in Windows 10 and WDs case. Thanks again for your help