RMA Application Error: Name Address must be entered in Latin

Dear All,

My external Passport Ultra 1TB HD has failed and while still being on warranty I’ve decided to return it for a replacement. My WD Online Account has all the required personal details filled in, including my U.K. home address. The HD has been also registered and linked to my account.

When filling in the RMA form I get to the ‘Address Section’ and cannot proceed due to an error: “Name & Address must be entered in Latin-based languages only”. I’m using English and avoid any special characters such apostrophes, dots, commas etc.

I tried using my iPhone (Safari) and later MacBook (Google Chrome and Safari) but still getting the same error. Is there anything I could do to resolve this issue? Maybe a Windows based PC with IE?
I would appreciate any help and advise.

Many thanks,

Mr. K Montgomery

Call WD, You must be in the spanish language section of the site.

1 Like

Hello,

I recommend you email support for assistance with this issue.

Hi Mr. K Montgomery
I am facing the same error - “Name & Address must be entered in Latin-based languages only”.
Can you please advise how you overcame?

Tun

I also have the same Problem. When will this be fixed?

I also have this problem.

I also have the same problem. I cannot get an RMA number.
When I try to add a new shipping address I get the following error message.
“An error was encountered displaying the address.”
I tried different formats & different browsers but the result is same.

Many have complained about the same error in the WD community page. But you have not solved the error yet. why do you keep a webpage that doesn’t work?

My drive is dead. I have only 2 days left to claim warranty. I am not sure whether I will be able get a replacement drive or not.

same problem here. obviously an error and one that needs to be fixed immediately

Same issue here. I raised support ticket two days ago and am still waiting for a reply!

I have this problem to

I have escalated this topic for our programmers to look into.

I have the same problem also.

Can I get one of you to private message me a screen shot of the error message? Also, can you include the address bar in the screen shot? Thanks.

After doing some investigating, I realized that what you are all seeing is NOT an error. It is actually meant to be an instruction. We will see about how we can clarify that better.

And just so you all know, you have been creating RMA’s. As far as I can see, you all have active RMAs. If you created a standard RMA, then you need to ship your drive in to complete the RMA and get your replacement.

Unfortunately Bill that is not correct.

I have the same problem as stated numerous times above. It IS an error because it is not possible for me to continue with creating the RMA, the ‘Continue’ button is greyed out.

Up until this point I cannot see that any RMA’s have been created in my account. I am requesting an ‘Advanced RMA’ so until I provide a valid shipping address (that clearly must be void of any Latin characters) how can a replacement disk be sent to me?!

Just to inform you, I am also waiting for a response from the WD support team regarding this (3 days and counting) so it seems the support from WD at the moment is pretty poor (as well as the quality of my drive which is failing after less than 12 months!).

Hope this issue can be resolved soon?! I look forward to your response.

Friendly (albeit frustrated) Regards,

Gary.

I’ve asked if someone can private message me a screen shot of what the error looks like, including the address bar. No one has responded, so I can’t effectively investigate the issue. For the others, I know for a fact that RMA’s were created, though not for you.

What browser and operating system are you using? And what country are you from? Have you tried another browser? I need to see what the page looks like when it stops working.

I will test again from this end.

1 Like

I tried to make an RMA today, and had the same issue:

Name & Address must be entered in Latin-based languages only

I even tried to use a shipping address different to my billing selected address, and that definitely does not work.

Browser, Chrome and MSIE. your form is broken!

I am guessing the Field Headings and actual fields are not correct. Also why do you have to “Save a new Address” before submitting a RMA? (it still does not work then) if I fill in the full address, this should be sufficient for a submission.

I have also noticed in my Account your system adds a , (coma) after the city name. this is impossible to remove and added my your system. it this why it is failing?

Bill:

address url is: https://westerndigital.secure.force.com/ind/ID_CreateRMA

I’m experiencing the same error on the same page as everybody else - running an updated version of Firefox on Win10.

Bill, I’m not seeing a clear indication of how to send you a PM.

We haven’t abandoned this. We’re still reviewing it.

@Darkmoon

The “Name & Address must be entered in Latin-based languages only” is not an error. It’s an instruction.

Also, if you are attempting to create an Advanced RMA, your credit card billing/shipping address must be in the same Zip Code. Otherwise, you won’t be able to create the RMA.

its was in the same zip code exactly the same as the address drop down, but it just kept returning back the the same page.

the Advanced RMA does not work. I have been told WD Support by phone it is not an option at this time.

more info here: Three out of three new WD Red4TB Drives bad & unable to create RMAs