Restore MBL (Lost all data?)

I tried to restore my MBL by enabled SSH, and entering  “/usr/local/sbin/ noreformat” in Putty.

But… Afterwards the only folder left was “public” and it’s empty. I tried to look in /DataVolume/shares/Public in Putty, but they are all empty. Have I lost all my data, or is there some way to retrieve it. 
SOS please help

Do the shares still show up under shares in your dashboard?
If they do, rename them… For example Movies to Movies1 back to Movies
reboot the mbl

If the shares don’t show up under shares in the dashboard, recreate the shares
reboot the mbl

Your user created shares should show up under /DataVolume/shares/

/DataVolume/shares/Public should just contain Shared Pictures, Shared Music, Shared Videos, etc

Yes the shares still show up on the dashbord and in /DaraVolume/shares/Pubilc/Shared music… etc.

But it looks like they are all empty.

But are you saying that renaming the Shared Video/Music/Picture folders should “bring back” the data?

btw. thanks for replying :) 

You must have messed up when you ran the script if the data in the Public share is missing because the script doesn’t even touch the Public share when noreformat is specified.

What were the symptoms that led you to running the script?

Mmm thats bad news.

I was unable to update the firmware, and i still can’t update? the current firmware is 02.10.09-124