Remote working funny

Hi have recently upgraded my wd live streaming player gen 3 to the latest firmware. I am not sure this has anything to do with my remote but the problems started soon after that.

The power button, on the remote, no longer turns the unit On or OFF. The OK button acts as an enter button when using the keyboard for entering Network password etc. All other buttons work fine.However, if I am using Netflix or Youtube the on screen keyboards work fine.

Also the player works fine with the Apps for android and iphone.

I have used the reset button, on the player, and reset it a few time without any improvements.

any help would be appreciated.

thank you

to cut a long story short … so it’s just the “Power” button that is’nt working ?

no its also the OK button used when selecting characters from the keyboard.  If you press the OK button then it acts like the Enter key. This particularly annoying when entering the password for a network because every time you try to select a character then unit tries to connect.

ok, sorry

So, you’ve tried the “Reset Hole” … have you tried via the GUI the Factory Reset as well ?

Setup > System > Device Reset > Reset All Settings Back to Factory Default

and, i don’t know … silly suggestion, changing the remote batteries