Remote connection to mybook live hangs/slow using WD2go

I am using a 2TB Mybook Live with the updated firmware and connected to a Dlink DIR825 router.

I am trying to get WD2go to work properly however any file transfer I attempt just seems to hang and never actually transfer. I noticed the message on the Mybook Live Dashboard which says I am connected but its a “Relay connection established” Then the next message is “For better performance, establish a direct connection by enabling UPnP on your router.”

I have set the UPnP on the Dlink router to be active.

I still received the same message from the Mybook after a long time for it to search for the connection.

I have rebooted the router and Mybook but nothing seems to fix the useless WD2go connection and I continue to receive the “Relay connection established” message.

I have already tried WD support but received no reply.

I hope I can get some help here!

You could try assigning a static IP to the My Book Live, then making sure ports 80 and 443 are assigned to that IP on your router. It is possible that something else is taking one of these ports. We use uPnP to try to open up these ports, and if it fails, we resort to relay mode. In the future, we will allow you to set these ports within the My Book Live to other than 80 and 443.

I tried what you suggested (to the best of my ability) and it has just made things worse. Now the mybook live states the connection has Failed.

Perhaps I have not done things correctly… I have included screen caps

First I created a static IP in the mybook live:

Then I set that IP address and the ports you mentioned in my dlink 825 router: 

Then I received this result from the mybook live:

Now the mybook live states connected failed… perhps I have done something incorrectly

I think you have this setup wrong.

The DNS server you are specifying is likely your gateway. You should change the gateway to be

The DNS servers will be reported by your router. They do not start with 192 IP addresses. If you cannot find them, you can use google’s free DNS server addresses : and

On your router setup, try setting the protocol to “both”.

WDTony thanks for your patience!

I have reconfigured as you instructed, however still no proper connection.

This is the current static setup for the mybook

This is the remote connection message

This is the change I made to the virtual server ports on the router (changed to BOTH as you suggested)

This is the router status window showing various IP addresses…

Do you have any further suggestions? Before reconfiguring the router I reset it back to factory settings and re entered the virtual server ports and since it just reported as its DNS servers I changed it to and

I was told by WD support to connect the mybook directly into my DSL modem (3com Home Connect model 0740 - just a modem with no built in router) and try to connect from an external location. I did and the mybook LED just glowed red, never turned green and I could not connect externally thru WD2go.

The router I have is a DLink DIR-825

I also tried putting the Mybook IP address into my routers DMZ setting, but that did not establish a good remote connection either.

I can’t think of any more ideas that would help set this into direct mode. What other devices are on your network.

Also, we have noticed that some routers don’t correct support uPnP. They say they are opening ports, but don’t actually do that. Did you check to see if uPnP is enabled on the router?

The only other other thing I can think that is causing this issue is that you are double NAT’d (the most likely scenario). I stole some definition from a web site, but you can easily google this as well.If this is the case, there is not much you can do about it - or us.

NAT vs. Double NAT

In a typical home network, you are allotted a single public IP address by your ISP, and this address gets issued to your router when you plug it into the ISP-provided gateway device (e.g. a cable or DSL modem). The router’s Wide Area Network (WAN) port gets the public IP address, and PCs and other devices that are connected to LAN ports (or via Wi-Fi) become part of a private network, usually in the 192.168.x.x address range. NAT manages the connectivity between the public Internet and your private network, and either UPnP or manual port forwarding ensures that incoming connections from the Internet (i.e. remote access requests) find their way through NAT to the appropriate private network PC or other device.

By contrast, when NAT is being performed not just on your router but also on another device that’s connected in front of it, you’ve got double NAT. In this case, the public/private network boundary doesn’t exist on your router – it’s on the other device, which means that both the WAN and LAN sides of your router are private networks. The upshot of this is that any UPnP and/or port forwarding you enable on your router is for naught, because incoming remote access requests never make it that far – they arrive at the public IP address on the other device, where they’re promptly discarded.

One example of a likely double NAT scenario is if you’ve ditched your landline phone in favor of Internet-based phone service (such Ooma or Vonage), and as a result have a VoIP adapter plugged in between your ISP-supplied equipment and your router. Another is when your ISP gives you a DSL/cable modem with an integrated LAN switch (i.e. more than one LAN port) and/or wireless access point, and you connect your own router to it.


I have a regular “old School” telephone and telephone line DSL with simple 3com DSL modem. No VoIP phone or anything like that. Not cable DSL. Phone Line DSL.

I dusted off an old DLlink 604 router and connected it directly after the modem. WOW all of a sudden I finally had a direct connection on the MYbook for remote access. Great stuff. I then reprogrammed the newer DIR 825 router as a wireless access point and attached it to LAN port 4 of the old 604 router. There is a PC in port 1, Mybook in port 2 and Imac in port3. I have a laptop and xbox 360 which connect wirelessly.

Worked great for about half an hour then all of a sudden the usual message returned “relay connection established - enable UPnP on router”

Of course the UPnP is enabled, the mybook said to do it so thats the first thing I checked. It was done already.

I don’t understand why WD produces these products that don’t work with common industry standard routers.

The whole reason I purchased the MYbook was to have the remote access and it doesn’t work. Whatever connection the relay connection is… its useless.

Telus is my internet provider. Anyone else with Telus having this issue?

Not sure if this is too late for you, but I have just spent days trying to resolve a similar problem. The issue seems to be with the Dlink 825 router, since it all worked fine with my 625. After trying everything I could think of (including hacking static routes because the 825 doesn’t support them for wired connections) I tried assigning the Mybook Live an IP address outside of the range of addresses used by the DHCP server. And it worked! Not sure why, but sometimes I ddn’t question these things.

I can access it through WD2GO on my iPad and Android phone and Time Machine is working again. Hopefully this helps.

Thanks for the reply… Yes I resloved my issue in a different way. I dug out my old beat down dlink router and used that and changed the 825 to an access point.

That solved it after a bit of messing around.

Great that you got it to work and I think I will also try your solution


What made a big difference for me was:

  1. Setting the QoS (Quality of Service) in the wireless router for the MyBook Live MAC Address to be at the highest available - with Netgear WiFi Routers at least, they assume all connected devices are only transferring files, not streaming media. As a result, the ‘low’ QoS was assigned by default. Traditionally the QoS is used for ensuring voice conversations on VoIP are not broken up by someone transferring a large file via the same wireless router.

  2. Set the IP address for the MyBook Live to be static.

Before I made the above changes I was getting broken video on replay, but now all is fine - WD should add these two points to their instruction manual, because it would at first appear that the issue is with the WD hardware.

Hope this helps.

i have the 825 as well.

-in the MBL, set it to DHCP.

in the 825, go to the list of DHCP connected devices.  I’m sorry, i’m not home so I can’t remember which tab.  You want to “reserve” a dhcp address for your MBL.

do that, reset all that virtual server stuff, and then open those two ports to that reserved IP address in you router.

disclaimer: i’m not streaming or doing wd2go or anything.  But I didn’t see you actually reserve an IP specifically for your MBL in any of those screenshots.

I played around with my network until I realised that there was a bandwidth bottleneck in my modem/router (Netgear DGN200) . It was especially noticable if I was watching a video and someone was downloading one off the internet at the same time. I fixed the problem by replacing my 100Mb DGN200 with a Netgear DGND3700 which has a 1,000Mb router.

To increase coverage I added a Powerline extender to which has a Wi-Fi  rebroadcaster at the remote end - this links back to the router via the power cables (much better speed than a wi-fi extender, which relies on recieving a good wifi signal from the main wi-fi unit).