[Solved] MyBook Live external connection very slow

Hi!

SOLVED: I disconnected from the wired net and tried via the wireless net, worked good again, then disconnected and connected to the wired again, works well again. Will update again if anything happens.

EDIT: Tried from another external computer and it works alot better, this problem has to do with the first external computer I tried with.

My MyBook Live works great at home but when I try to connect from a remote connection outside of my Local Network it is very, very, very slow. I map up the drives via the WD2Go internet portal and they appear as they should on my Windows computer as drives Z: and Y:

However when I try to go into the drives it takes an eternity to connect to the drives, let alone opening files, selecting them and copying new files is just impossible. Clicking cancel on file transfers also is slow to respond.

 I’m using a Thomson Gateway TG787 router at home, everything is WIRED, no wirelesss, not even on my external net I’m trying to use. Firemware is all up to date on everything.

Is there anyway to see what might be blocking the connection? Log files of somesort? 
I see  WD2Go is using port 88

Here is a picture with the transfer speed when I try and copy a small file to it, 153 bytes/second is a joke! Any clues?

  Transfer

When I map the drive it also states that the certificate cannot be verified. Could this be the problem (via SSL that is).

have you had any results in fixing this?