Web based remote access with My Book Live Duo


I am unable to remotely access my Live Duo via the web. Does this product require a static IP address for this function to work? I believe it does. I am on Hughesnet which does not allow (unless I purchase a static IP) access via ftp. I know the product uses the site wd2go for remote access. What protocol does wd2go use?  The HN 9000 modem I was supplied by Hughesnet is also a router. I am hoping some very astute user can help me with this. Thank You.

Hi, no, it should also work with a DHCP configuration. The protocol used by wd2go is webdav, do you get any error messages when you try to setup the wd2go account? Just in case check the link below so you can review the steps.


Cannot establish remote access connection. Make sure you are connected to the Internet. (Error 31520)

Check if you have the latest firmware installed, if you do, backup all of your files and select the option to do a factory restore from the my book dashboard. 

Firmware is up to date and has been.

Please give me a valid reason why you think your other suggestion will help. Don’t misinterpret this as a snotty reply I want to know why you think it is of benefit.

I would suggest using a computer at a different location so as to eliminate the remote locstion as being the problem.

I think that is a good idea.

That did not work.

Make sure you have UPnP enabled on your router, if it supports it.  

If it doesn’t, you must follow the instructions for “Manual” port forwarding.

My router is a Buffalo WZR-600HP and the check for UPnP is and has been checked. Thanks.

It appears you have 2 routers on your network, have you tried using the one supplied by your service provider? Also, when I log into wd2go remotely, there are 2 security phases. First, I am asked for my email and password and then I’m asked for a Network Drive Password. At what phase are you getting the error message? Note that you will only be asked for a network drive password if you assigned one using the dashboard under Users.

Jmaxim…you are better than most. Yes there are two routers. My ISP provides a modem/router.  I am not sure what you mean  “…have you tried using the one supplied by your service provider?” Might you clarify for me please.

When I am at wd2go the icon has an orange yield icon and when clicked it reports I am offline

Your ISP can provide you with one of 3 types of router. A modem only with one ethernet port, a modem with a built in router which usually has 5 ethernet ports or a wireless router which normally has 5 ethernet ports plus wireless capability. If your ISP provided you with a modem with a built in router you would not need an additional router unless you need more ethernet ports and/or wireless capability. It appears you are using an additional router (Buffalo) so my suggestion is to not use the buffalo router and use the one your ISP provided.

I have not been able to figure out where you are seeing the yield sign at wd2go so try the following:

  1. Navigate to www.wd2go.com 

  2. Enter your email address and password

  3. Enter Network Drive Password

Ler me know at which stage you are seeing the yield sign or error message. If we can figure this out then maybe there won’t be a need for you to touch your router configuration.

My ISP (Hughesnet)  HN 9000 router/modem has one network out port. I hook that to my Buffalo and from the Buffalo I have 3 wired networked PC’s. If I was to hook the Hughes directly to my PC I am not so advanced that I can figure how to then keep the other PC’s networked with cat5e. I call it a router/modem because I have read that is what it is in various forums.

I see the orange yield after I log in at wd2go. I have no problems logging in.

I superimposed the warning message (which pops up when I click on My Duo) over the screen I am presented with after login

Thanks for your help

Ok, was able to duplicate the error message you are receiving but only after I power off the MBLD. So my silly question is, do you turn off your modem, router or MBLD when leaving your location?

No, never powered off.

WD has determined that my unit is defective. I spent time with second level tech support. They are sending me a new unit. Thanks again to all that came to my aid

I thought about it and my conclusion was the exact opposite, that the drive is OK and your modem/router may be at fault. Anyway, glad you got it squared away and hopefully you will be accessing your drive remotely very soon.

WD support’s typical answer is “If we don’t know what’s wrong, it must be defective.”

I wouldn’t be surprised if your replacement unit behaves the same way.

I don’t think it is either one of those issues. I think everything is working . I must give WD  the opportunity to show the Duo does what WD claims.