Remote access not working today, worked fine yesterday

I use the WD mobile app frequently. I used it yesterday without any problems. I have had the MyBook Live for over 2 years with no issues. The error message say can not access internet. I did a reboot and can access the drive within my home network, but when I look at the remote access page in settings, there is an error saying unable to connect to the internet. My network connection the internet is fine. I accessed my laptop at home remotely from work. I tried turning remote access off then back on, but with the same error.

I’m seeing the same.  Wonder what’s going on at WD.  Hopefully this will be resolved quickly.

There’s a sticky in the other NAS forums about a service outage.

But supposedly it ONLY affects devices that are connected to the Cloud service via a RELAY connection.

If your MBL is working via Port Forwarding, it’s not supposed to be affecting them.

great, thanks Tony!  I am using relay, thanks for the information!