Remote access disabled

My Sonos pulls music from MyCloud. Today it stopped working. When I try to access music using MyCloud app I get a message saying remote access disabled. I am guessing I need to update something, but not sure how.

i assume you’ve checked the settings in the dashboard ?

I can’t open dashboard either

When did all of this start and what, if anything, were you doing? Are you on Windows, Apple, Linux etc.? Is your My Cloud suppose to have a static IP address or is it DHCP?

The more info you provide the better chance someone here can help.

Yesterday morning I was at the gym and tried to play music thru the My Cloud App and I got the message that remote access was disabled. Tried using Sonos that night and it couldn’t play anything. I have a Mac. I tried to access My Cloud on the computer and says unable to open. The actual unit has a flashing light on the front

What color is the flashing light on the front of the My Cloud?

The My Cloud User Manual ( lists what each of the light colors both static and flashing mean.

I went out of town for a few days. I came back and it is working fine. Will it automatically update periodically?