Reformatted Drive: Unreliable Wireless Connection

My passport wireless device has been reformatted several times. I need help!!

My steps for establishing wi-fi connection are:

I connect via USB and the drive is listed as “G”. I double click to open drive and I receive the error that “parameter is not correct”.

Using the Knowledge base article I discovered that my drive needed to be reformatted. I reformat the drive and rename it “FilmPassport”.

I disconnect from my Win 8 OS PC.

I then connect to the passport device via a wireless connection using my samsung tablet and there is no data on the device.

I access my drives web address and verify that the firmware is up to date. I verify that the settings allow for data to be transferred over the network.

The USB Drive Lock option in the Dashboard was off.

I then reconnect the device to my PC and it recognizes the “FilmPassport”.

I load data onto my device and remove it from the PC. I then attempt to connect using my samsung tablet but it cannot connect. 

I reconnect the drive to my PC and it reads “G” and the cycle starts over again.

I have previously accessed the knowledge base to repair my drive following the steps to download and install software for the passport on win 8 OS. It advised me to plug in my wd device after the pc rebooted. After the reboot I plugged in the device and there were no noticeable changes.

I opened a case with the WD support team, [Deleted] I asked if there was a way to restore the drive to factory settings and I was informed no. I purchased this drive in November of 2014 and it is too late to return it. If I cannot repair it I will have lost $200.00. Can someone help me please?:cry:

Other than to tell you that there is MOST CERTAINLY a way to restore it to defaults, I don’t have much to offer.

There are several methods, all described in the manual on Page 47.

But I can’t imagine why after transfering data via USB, that it “disappears.”

Might be a dumb question but I have to ask if you tried the following or is that what you mean by reformatted?

Page 47…

Summary of it:

Connect to MPW over it’s wifi
navigate to
Click the Admin icon

Under “Restore Factory Settings” click on System and Disk.

Hi PuDLeZ,

Yes I did that step to restore to factory settings, twice, actually. I forgot to mention that.

But when I stated reformatted, I meant going to Disk Management, and formatting to NTFS. When I would plug in the harddrive and it would display “G” for drive name to where I could not open it, within Disk Management, it would display the “G” drive with the letters “RAW” for the file system instead of NTFS. When I would see that, I would format the drive to NTFS and go from there.

Thank you for confirming that you tried that… Well I do have something else you can try (ssh in and setup the hard disk on the device) but first I want to confirm that it can detect the drive fine…

If you don’t have putty on your Windows machine, download it (you just need putty.exe)

Now connect to your MPW Wifi and enable ssh access (under admin) in the webui

Open Putty and type in for the hostname
     user: root
     pass: welc0me

Type in the following line
fdisk -l /dev/sda && fdisk -l /dev/sda

Please share the output of the above command.
Note: If you’re not familiar with putty, just selecting the lines will automatically copy the text

What kind of Bozos in WD support are telling you there is no way to return to factory defaults?  Must be his/her first day!  As Tony says, there is, and here is the info from WD with More info:

Important – the MPW must be ON when you do the restore or you will cause major problems that are hard to recover from.  MPW can not be connected to a computer, and it needs to be fully charged.


System Restore (No UI):

*Do NOT have an SD card in the drive.

  1. Power ON device. Wait till both lights are solid (Fully Booted)
  2. Hold both buttons in for 10 seconds (or until the device reboots)
  3. When it boots up it will be in a fresh state, with the exception of the drive. The drive is not touched with this restore.

Make SURE unit is ON before restoring to defaults.

Once restored you can set it up like it was brand new again.  If you don’t have the full user manual to refer to, first download it fron WD Support and refer it for set up procedures. 

Go for it!

Hi PuDLez,

I’m just giving you an update. I didnt want you to think I had given up. Last night while waiting for my pc to load Disk Management, I fell asleep. It does this only when I need to reformat the passport drive. If I have the drive plugged in and open disk management, if the drive reads “G”, it takes hours for it to load the “Virtual Disk Service”. Pretty annoying. So today, I plugged it up and left it and it loaded to where I could format from RAW to NTFS. I now need to let the drive charge because it is red. So, hopefully once it’s charged I will be able to get a wifi connection. If not, then I will have to start over again from formatting.


Hi Mike27oct,

Thank you for confirming that there is a way to restore the drive. I will give this step a try once I finish with the steps advised by the previous representative. Hopefully one of these will work.


We are not “representatives”; we are users like you!

1 Like

Oh ok, LOL, well then I owe you guys a really big thanks for reaching out and helping me even though its not a paying job!!


Hey Liam,

I’m laid back and know life happens :slight_smile: So I messed up and one of them was suppose to be fdisk -l /dev/sdb but that’s ok, I see that the MPW is detecting your drive just fine and the values look ok. In my experience, I have not had luck with the NTFS filesystem and tablets/phones. I always use exFat since it’s more “friendly” with devices and computers. Try reformating the drive in WIndows again but select exFat instead of NTFS.

P.S. You can reformat the disk by going in with ssh and triggering


but you have to do it twice. The first time the system (at least mine) can’t stop it totally so it fails but it changes the partition so upon reboot, it’s not setup to be used. Then you just connect to the device again, ssh in, and trigger it. Once again, you might see things like “Invalid argument” or “No such file” but that’s ok, it’s just because the drive was setup to be used. Weirdly or “buggy” script from WD but I suppose people don’t normally see the output…

I personally think the ssh option is best but it does take longer and more involved. 


The original format of the MPW was exFAT. My MPW has remained that way and works fine w/Windows PC and mobile devices in both iOS and Android devices.

Hey Guys,

So here is the update. My case has been referred to the WD Support team and someone has reached out but I missed the call. I replied and hopefully they will call tomorrow because I need the help.

I thought everything was great.

I reset the drive by holding down the power button and battery check button at the same time. The drive rebooted. I connected the drive to my PC. As suggested, I decided to format the drive under exFAT file system.

I removed the drive from my PC and connected the drive to my network and it connected with an error. 

I used my tablet and connected to the “My Passport” Network. That connection was successful.

I then followed the prompts to connect to my home network. It stated the connection was successful, and it would reboot the device.

Once rebooted, I reconnected to the Passport device using my tablet. I then used the cloud ap again and tried to view files on the drive and i received an error stating the device could not access the wireless network, I believe it was error number “0001” or “1000”, or something similar.

I rebooted the device and then plugged into my pc. I received the popup error that there was an error with the drive scan now and fix it. I decided to use the Windows repair program and it attempted to run the repair. After several minutes it produced an error stating “Error Checking (FilmPassport (G:)): There was a problem repairing this drive. Windows was unable to repair the drive. Close this dialog box and then try to repair the drive again.” I tried this several times and even rebooted my pc and tried again to no avail.

I then attempted to run “chkdsk” command under admin rights and it stated “A media error has been detected. Bad sectors may be present on the volume. The volume will be checked for bad sectors.” Following that a pop up error stated “chkdsk.exe - Device Timeout. The specified I/O operation on G: was not completed before the time-out period expired.” I performed this several times and received the same output.

I gave up and decided to reset the device one again. This did not go as planned. It showed, as the user manual states “blinking red with power and battery status and wifi LEDs alternating: Drive has a problem. Contact WD Support.” :confounded:

I decided to reformat under NTFS. Reformat was successful. I tried another reset but it was unsuccessful.

I will be waiting for support to reach out to me tomorrow.


Hey Guys

I couldn’t sit here without doing anything.

I plugged the device into my PC and ran a Norton virus scan, nothing was found. I then tried to rescan using the windows drive repair program because I got the drive error pop-up again. I got the same error where the scan could not complete. I then decided to reformat under the exFAT file system.

Reformat was successful.

I then removed the drive from my pc and it was finally able to produce its wifi capability. Using my tablet and the WD App, I connected to the “My Passport” wifi. It took me several tries to get the passport device to connect to my home network.

Once connected it took a reboot of the device for me to be able to load my “My Passport” Web page.

Once I loaded the page I was able to access the passport device and its content (which there was none) from my tablet.

I then connected the passport device to my PC and I loaded a few movies, music, documents and pictures to test it.

I removed my drive from my pc and it connected to my home network.

I accessed my smart tv options and was able to view the videos, pictures, play the music from the passport device via the wifi connection.

I received this message from my personal “MyPassport” web site.

"Drive SMART failure

 The drive self-check failed. Please contact WD customer service for assistance.Code:0003"

I am still unable to successfully run the repair scan nor a chkdsk scan.

I don’t believe this drive will hold out too much longer.

I will post an update after assistance is received from the WD rep.


Stop right now doing ANYTHING with the drive.

Turn it off. Pack it in its original box, ready to ship back to WD for replacement.

The drive is now dead. It failed internal SMART tests, which means it is really dead. You are just doing more and more damage to it, and have been for a while. Leave it be now. Let it rest in peace, before it rests in pieces, when you get so frustrated that you smash it.

Wait for WD to call you back again, and go from there. You said you purchased this drive in November of 2014, so it should still be under warranty, and will be replaced. Unless you have accidently damaged the drive, or done something to void the warranty.

Hi RoderickGI,

I must admit, I needed that laugh.:smileyvery-happy: You cracked me up but I hear you loud and clear. It will be packed up and ready to ship. Thank you and everyone else for assisting. 


Happy to help. Pleased to hear you didn’t resort to violence. :laughing:

Hey Guys,

Spoke to WD support and they confirmed it needs to be replaced. I have submitted the RMA request and should have a new drive soon. Second time’s a charm!! :robotwink: