My Passport Wireless--Cannot Reach Dashboard Cannot Reset or Load FW FromSD Card All as described in Manual

The drive was sitting idle for a couple of months but on charge. Tried to use it normally but noticed after it booted normally from indication of power and wifi lights, within a minute both lights began flashing red.

Tried to reset per manual and to load latest FW from SD card per manual, but neither produces any changes and remains to be unreachable. I see the drive in my wireless network list on my iPad, but unable to make connection or reach the management dashboard. I am attempting make the connection while both lights appear normal.

When connected to a PC, I can see the files on the drive but cannot access dashboard or use with mycloud.

Please help with some suggestion to manually restore drive using a different procedure other than the manual restore explained in the manual as this is not working.

Drive is two years old and replacing it is not an option, I’ve spent enough!

Try reset/restore again. See this link – it was flagged as a solution!Cannot connect to my passport wireless at all

Thanks Mike. I think I indicated in my post that I had followed the reset procedure per the manual. I always end up with flashing red lights. The SD card procedure for reloading or up dating the FW fails too as reported.

Any new suggestions or workarounds from tech support would be welcome.

I’ve seen the inside of the MPW from YouTube take apart posts. For me, reworking the board would be a snap. It’s nothing compared to the IPhone 5s logic board repair that do often.

The status LEDS on the case are helpful but extremely limited to pinpoint any general issues. Even the battery is suspect, though the status lights indicate full charge but do not for example indicate a battery that suddenly disconnects itself from the control board or simply is not capable in maintaining minimum supply voltage to properly power the drive or wifi module, another heavy power drain in normal operation.

As to any concerns of EMI or RF interference from other sources, wrapping the unit in aluminum foil will eliminate that just for testing to see if normal operation is possible.


Jerry. this is a user forum; I am not a WD support person. If you want support:

In a previous life I was once an electronic tech person and dismantled and repaired some major electronic equipment; both military and consumer gadgets. But, in today’s microscopic e-world, there is no way I would open up my iPhone, iPad, Kindle tablet or MPW, etc. and tinker inside. If you do this, you are on your own and risk warranty voiding. Good luck.

Mike, funny what warranty??

It’s two or three years old.

Micro soldering is not black magic, or for only the super talented, but it does require patience and the desire to master it along with a few pieces of reasonably priced equipment.

I know how to contact support and the PM’s if needed but there is no repair outlet that I know of provided by WD. Support does not repair anything but return to China and charge 85-90% of a new device swapping you out with a refurb from China.

Look beyond the box, this forum should support all users, in exchanging more technical information for those among us who want to dive deeper into the product. They buy equipment as well and therefore are indeed users. Why not support them as well by encouraging these discussions?

By the way if anyone is interested in sharing this info or interested in what lies beneath the plastic, drop me a PM or just reply here. My goal is to get this nice expensive little guy back in service, but I will certainly retain and regain the 2TB drive and likely be able to keep all my files. At the very least, I’ll have a SATA drive without spending another dime. Cheers!!

Well, how was anyone to know it was 2-3 years old? If anyone has ANY expensive gadget still under warranty, they should not try to fix it themselves – get the thing fixed under the warranty.

I’m not discouraging anyone to not “take the clock apart to see how it ticks” I did plenty of that when my vision was good. Anytime I need to do close work today, it is a real visual chore for me now.

Mike, how is anything you posted related to my last post. This drive isn’t a brain or complex control system.

Unless I am missing something it’s out of warranty, I have no other choice but to remove the drive and at least regain use of it. I certainly expected it to last a lot longer!!

Jerry, chill. Replies are not always just for the OP. Others read this stuff, and some of my comments were also meant for “others”.

I offer two possible explanations:
If the drive were not being used for a while the battery may be discharged - which red led would indicate. If so a FW update may fail since this require a certain amount of battery left.
Resolution in this case would be to charge the MPW and then try FW update. Maybe a soft reset is needed too.

If the case is that the drive was connected to a power outlet for several months the opposite may have happened - a overcharge of the battery which WD warns for. In this case I do not know how to fix it. But I would certainly try the WD support even if the drive is old.

1 Like

Mike, why should assume that no users here are interested in solving other than simple solutions contained in the manual?

Simply because you do not care to go deeper into more quirky issues of this product, others certain may. It’s an open user forum for everyone.

Regardless of your own personal interest to address these areas, your’s is not the voice of reason here, only an opinion. If you have no constructive to add, fine, but admonishing others who do is A bit over the top.

Jerry, since you want to continue admonishing me AND putting words in my mouth, there is nothing else I want to add to this conversation except that Stangen passed on two very good ideas, so why don’t you check them out and move on.

Thanks Stangen.

Early on the battery was my thought as well which I addressed by fully discharging then followed with a normal full recharge.

Afterwards, holding the wireless button for 2-3 seconds causes the wireless LED to indicate a full charge. With no additional definitive information to pinpoint the passport failure to boot, I removed the drive and battery from the case then monitored the voltage of the battery while under boot load. It maintain open circuit voltage indicating that all individual cells neither shorted or opened. I also monitored it during the boot failure and found nothing remarkable.

Visual inspection of the board under microscope revealed no solder issues, or PCB cracks. Connecting the SATA drive to a PC SATA interface showed no issues with read or write test or a surface scan. All files that were on the drive were all present and intact.

The issue seems to be a boot ROM one possibly related to the wireless interface PCB since control of the drive is under the direction of the wireless interface. This is all I know this far. I will try to find a schematic, doable I believe, but not readily available.

I will see what support would be willing to offer at this point given their limitations regarding component failure and the fact that my passport is beyond warranty. I also suspect that however repeatable this issue might be or to what degree it remains part of the failure of my device I’m not alone with this failure.

On the matter of overcharging the battery, it’s not clear whether this, if truly an issue, is a battery design flaw, which is indeed a defect, or the charge control management of the Passport, it is a correctable defect of the Passport product that should not be passed along to the end user as a warning!

Can one imagine the impact to the iPad if such an issue was allowed to be passed along to the end user?

I admire your tenacity :grinning: I would have given up much earlier.
Battery problems are quite usual here in the forum -possible the weak spot of the MPW. I am quite particular about chagring and discharging of my MPW hoping to make it last as long as possible.
Wether this is the cause of your problems I cant say. I wish you luck!

Thanks I’ll post additional comments as I narrow in on the actual issue. I did check in with WD support. Completely a waste of time, but that’s what I expected.

Parts for the Mypassport are not made available by WD. Odd, in a way, because this is a CLOUD device containing a wireless interface just like an iPhone with a similar complement of replaceable components. The drive itself is not so much prone to failure and not serviceable, but the interface card consisting of the battery charging circuit and the user interface, certainly is, and more so than an iPhone even! There are litterly thousands of smart phone repair facilities available to anyone around the globe with plenty of access to the exact SMC (surface mounted components) used in smartphones. Why not Cloud devices?

I was fortunate enough to find a working 1Tb MPW, for $95.00 on eBay so I did some further testing. My 2Tb MPW had a failed component on the interface board. The battery and driver were fine which was my belief from the previous tests.

The case of the MPW 2Tb is thicker than the 1Tb model because if the drive. So I used my original case and the interface card from the MPW I purchased and up and running with all my files intact and good as new. Considering the 1Tb MPW is over $160in today’s market and the 2Tb MPW is another $85 to $100 over that, the cost of the 1Tb model was well worth the price! The my original MPW was a gift. It’s a great product WD, but for god sakes, at least allow users the unencumbered freedom of repairing the interface board!!