Red power light but drives still work fine

I have a PR2100 which works great. I run a Plex server and store the files on a Terramaster D4-300 which works great. It is connected to the USB 3 port on the rear of the PR2100. When I first put this in use the PR2100 showed a red power light even though the drives in the D4-300 showed up fine and worked without issue. After a few restarts, the PR2100 power light showed the normal blue color. Things have been fine for a few months with very few power restarts that all went fine. Today after a power restart (both units) I am back to red power light. The drives from the D4 show up in the PR2100 and work fine. They are also visible to 2 different Win11 machines and work normally. Anyone have and ideas? I asked this to WD when this first happened but it their reply it was obvious they did not even read the email so that avenue is out! Thanks in advance for any help.

Hi @pics53090,

Please refer to the link below for My Cloud Alert Codes, Descriptions, LED Status and Email Notifications, and External USB Drive Will Not Mount, Not Seen, or Detected by a My Cloud.

Title: My Cloud Alert Codes, Descriptions, LED Status, and Email Notifications
https://support-en.wd.com/app/answers/detail/a_id/17203

Title: External USB Drive Will Not Mount, Not Seen or Detected by a My Cloud
https://support-en.wd.com/app/answers/detail/a_id/18918

Thanks for the info. Actually very helpful. However, after looking through and trying a few things, the issue still remains. It does show as error code 1124 which is “unable to mount USB device”. I did take the Terramaster unit off the PR2100 and attach to my computer to check it out, It worked just fine, shows all 3 drives as NTFS, and an error check shows no errors. As I stated before, the unit was showing blue light for about 2 months or more with no issues. As the drives are all functioning as they should even with the solid red light, I am going to continue to use as is. Any further info would be greatly appreciated.

If I’m not mistaken, the red power light indicates the discs being nearly full.

That is not correct. The light being red can mean many things. In this case, it thinks it can’t mount a USB drive, even though the drive works just fine and shows up just fine.

try a manual dismount from the dashboard

then a shut down of the nas - power off both devices

reconnect external USB drive data cable just to be sure the cable is in tight.

reconnect USB disk power them NAS power – which should start the NAS


I had to do this once
you could to a temp test with another external USB disk on the same port as a test

This issue has been resolved. There is some communication issue between the Terramaster and the PR2100. All looks good when the TM is plugged into a windows machine, but plugging into the PR generates the red light. I added a 4th drive into the TM and the issue resolved itself. All drives work fine and back to blue power light.