Receiver cannot play movies from EX2 Ultra withTwonky, any advice?

Hello community, i really hope you can help me.
I used to have some MyClouds before with Twonky installed. It was fixed by Lan cable to my router, like my receiver and TV. I never did any settings to the Cloud or Twonky, i just transered all MKV video files through windows explorer on the NAS. I could access the NAS with my receiver or TV to watch the movies, it even worked with my Tab when i opened the Network via VLC on it. No preview, pics or additional info. i just opened the folder, saw the list with names of the movies and opened the one i wanna see. Thats all i want.
NOW i got a new Cloud, the EX2 Ultra with 6TB. The support at WD helped me through updating the firmware to OS5 (I guess thaat wa not good) and explained me how to install the Twonky app and creating the shared folder in the Twonky settings. I am not a computer tech or programming tech, i am not good at this things.
Now i transfered all movies (about 585) into 5 different folders on the Nas. With my laptop i can open the nas with the explorer and can watch the movies i want, with my tab and the VLC it also works.
BUT the most important thing, my receiver from Harman Kardon, which sends it to the beamer, can access the cloud and the folders, but when i open a folder it will show me just for a second the list with the movie titles and then shows me the error: THERE IS A PROBLEM CONNECTING TO THE DLNA SERVER.
The receiver never did that before, with the other clouds it always worked noce and easy and i did not change any settings.
I checked many blogs worldwide and could read about FFMPEG problems, setting problems and so on. But there was no problem like mine. Maybe one of you experienced the same problems and give me some advice about settings or whatever??? And please excuse my english, thats not my native language.
Hoping to get any response or advice i remain with kind regards.

Hi @Mr.Tabor

Please refer to the link to check the article of My Cloud OS 5: DLNA Media Server Not Detected After Update: