Rebuild your My Cloud or upgrade the HDD on it

If your attached screen capture is from the new cloned 6TB hard drive then check the Diagnostic screen to see what it is saying about new drive. Also review the alerts notifications in the Alert icon (mycloudnotificationicon ) to see if anything there provides additional information on the drive error.

I ran into issues trying to use certain clone software to clone a first gen My Cloud drive. It was hit or miss. Some software just didn’t work to clone the drive properly I think due to the fact the My Cloud uses Linux. Clonezilla worked once I put the drives into USB to SATA adapters and didn’t use the desktop PC’s internal SATA ports.

Personally if I continue to try cloning a My Cloud drive and it doesn’t work, which I’ve experienced in the past on a first gen. I moved to following Fox_Exe’s method of restoring the My Cloud operating system to the new hard drive then manually copy over the user data from the old drive to the new.

Second gen:


https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt

WDD My cloud gen 2 hdd replace video

My first post but wanted to share my experience. I have a wd my cloud gen 2 (firmware is 2.xx)

I needed the hard drive for another purpose so I took it out. Had a spare seagate 3tb and wanted to see if I could put it in here. It worked but ultimately needed to go a different route. I used the video above and followed their steps and it worked. I tried so many other methods and downloaded virgin disk images but it didn’t work. It’s possible those disk images are for gen1 but I tried the method described above and it didn’t work. Here’s a quick summary of what I did (watch the video and download the files from the video).

got ubuntu on a usb (google instructions. very easy)
downloaded image files and loaded them onto the root folder of the ubuntu disk. there should be 5 image files, each 1gb and one is 2gb)
loaded ubuntu and opened terminal

in terminal, I wrote the following commands (can reference video for details)

sudo su
parted -l (this gives you details about the hard drive. my hdd happened to be /dev/sdb. Be sure to change the drive to your own)
parted /dev/sdb (now you are in the parted application on this selected drive)
rm * (this threw an error but the next step deleted the partitions anyway)
mklabel gpt
mkpart primary 1049kB 2149MB
mkpart primary 8591MB -1MB
mkpart primary 7517MB 8591MB
mkpart primary 2149MB 3222MB
mkpart primary 3222MB 4296MB
mkpart primary 4296MB 6443MB
mkpart primary 6443MB 7517MB

q (type q to quit parted)
mkswap /dev/sdb1
mkfs.ext4 /dev/sdb2

cd / (goes to root folder)
cd media (goes to media folder)
cd cdrom (goes to cdrom folder which is where the usb files are. you can use “ls” command to confirm that they are there)
cp sdb3.img /dev/sdb3
cp sdb4.img /dev/sdb4
cp sdb5.img /dev/sdb5
cp sdb6.img /dev/sdb6
cp sdb7.img /dev/sdb7

That’s it. now close terminal and shutdown ubuntu. unplug your drive and plug it back into the wdmycloud.

find the ip address of your mycloud and type that into your browswer. once it loads, agree and go through the setup. at this point, it defaults to a raid setup page that I don’t know how to access normally but it keeps going to this page. this is the page that you need. there is only one option to setup a jbod configuration which is basically a single drive configuration. i have a single wd my cloud so this was my only option. follow through the prompts and it will format. once formatted, everything should reset and work normally. I was able to see my full 3tb. then I updated the firmware to the latest version and everything continues to work.

I hope this helps!!!