Question about HD video network streaming stuttering on WD TV Live

Hi everyone,

I just picked up this new wireless bridge to use with my WD TV Live. I connected the bridge to the wireless network, and did a file copy test over to the WD TV Live over the new wireless network. I can achieve about 5 MB/s while copying a file through Windows Explorer. I also used Windows Explorer to browse to the WD TV Live and saw the drive that I have connected to it.

I played a file on the computer from the hardrive through the wireless network, and the file has a bitrate of 15 Mbps (1080p file). The file plays no problem on the computer.

When I go to the WD TV Live to play that same file but this time from the computer’s hard drive, it stutters.

So here’s the big question:

  1. Doing file copy tests proves that the wireless network can easily handle the throughput.

  2. Playing the file on the computer through the wireless network, from the WD TV Live’s HD proves that the throughput can be met.

So why is it that the WD TV Live cannot play the file without stuttering? Lack of processing power? If anyone could elaborate that would be great. Thanks!

Just to ammend a little bit here. After posting I remembered that uplink and downlink can be different for wireless products.

So instead I tried copying a file TO the hard drive connected to the WD TV Live. I still get about 4 MB/s. So it is a little bit slower but it seems that I have more than enough bandwidth there to handle 15 Mbps = 1.875 MB/s video.

Edit: Also just tried the same scenario with the PS3. Stutters too. I just wonder why during a file copy it can go so well yet while playing the video be so poor.

Ok, so with enough network tweaking and a FW revert back to 1.02.21 I get some HD video to work, but not my highest bitrate stuff.

I have tweaked the network settings to a point that I can copy a file to the WD TV Live at 9 MB/s. That is more than three times higher bitrate than my video. The video plays fine for maybe half a minute then starts stuttering. It’s like it’s playing at 25 fps instead of 30 fps.

It is clear that this device has network issues. I will begin exploring other options.

What is the file you are trying to stream. Post mediainfo here