Ps3netsrv on my cloud for Playstation 3 (ps3)

hi everybody

i want to install ps3netsrv app on wd my cloud.

i am going to load my Playstation 3 games and i will use with mutiman and cfw Playstation 3

about:

PS3netsrv stream PS3 Iso thought your gigabit network to your PS3, usefull if your BD reader is dead.

the module on first install create a directory /raid/data/PS3_ISO, you have to create a share within the webui of your Thecus called PS3_ISO
the application listen on port 38008
the applciaction accept all device on netwrok (0.0.0.0)

http://www.ps3hax.net/showthread.php?t=64811

It needs to be built/compiled with 64K page size memory patch. but how ?

here is te linux code adress.

https://github.com/dirkvdb/ps3netsrv–

Not tested:

PS3 NetSrv for firmware v4

1 Like

Thank you
How i install and test it ?

mv ps3netsrv_bin_v4.tar.gz /usr/local

tar -ztvf ps3netsrv_bin_v4

tar -xvfz ps3netsrv_bin_v4

./configure

make

make install

 is correct ?

Edit: i have tried with lates Firmware WDMyCloud v04.01.03-421 and its working fine. Thank you Fox_exe.

2 Likes

@dare1979

Can you help me how install it my cloud ?

Download, unpack, run:

tar -xvfz ps3netsrv.tar.gz -C /usr/sbin
nohup ps3netsrv /shares/Public/Iso_files

Autostart:

nano /etc/crontab
# add to end:
@reboot ps3netsrv /shares/Public/iso_files
2 Likes

Fox can i copy the file manually with WinSCP to usr/sbin a add the line to crontab?

my current procedre is:

i made a folder home/ps3 copy your file there and made a start stop script in etc/init.d

start)

/home/ps3/ps3netsrv /DataVolume/shares/PS3Root/

;;

stop)

killall ps3netsrv

then i start ps3netsrv after a wd restart with

/etc/init.d/ps3netsrv start &

manually

and if you start the ps3netsrv with crontab automaticly and a problem occur with ps3netsrv on booting, is there any risk that the wd nas willends in a  “boot looping” or your data is lost? or will the wd boot up normaly and wont only start the ps3server?

so you can accsess your files and ssh…?

  

1 Like

Copy ps3netsrv /usr/bin/ folder

nohup ps3netsrv /shares/PS3Root

PS3Root/PS3ISO >>> your İSO games folder.

1 Like

Thanks all!!!

I’ll try soon

1 Like

Its possible install ps3netsrv on MyBookLive 3tb?

I dont know how to complie but i think is possible  http://www.nasyun.com/thread-23766-1-1.html

Thanks in advance

please try only my advice

Sorry, dont understand…I have WD MyBookLive no My Cloud.

My Book Live uses Applied Micro APM82181 processor and a Debian Lenny distribution.

Thanks

Solved here:  http://community.wd.com/t5/My-Book-Live/HOW-TO-install-PS3NETSRV-on-MyBookLive/td-p/880757

i solved this problem, why you opened another post

I suppose because

a) fox_exe was kind enough to do a build for you
b) fox_exe was kind enough to give you instructions on how to install it
c) the other thread is about installing on a MyBook Live, not the MyCloud; most people only read the forum for the device they own.

I think that makes starting a thread on the appropriate device forum a reasonable thing to do.

1 Like

can i use it new update for my cloud ?

v 4.4.2

Any chance you can make this PS3 Netserv build available? recently installed cfw on my ps3, link is old/dead

My Cloud EX4

Fixed second post (Links to precompiled version for WDMC Gen1 (v4.x.x firmware) + Sources.

So I am running a WD My Cloud Ex2 Ultra. I attempted the steps in the above posts by Fox_exe.

Some things to note:

  • Nano is not installed so I had to use vi to edit the crontab
  • Every time I restart my NAS there is no line @reboot ps3netsrv /shares/Public/iso_files in the /etc/crontab file

I do not think that this is currently working for me. Even the ps3netsrv files disappears after a reboot. Will update if I figure this out this issue. I’m on the latest firmware, 2.30.196.

Thank you!