Problem; Yellow light burns; MBL offline


I have a problem with my MBL 2tb. When I start the MBL first the blue light burns for about 4 sec. Then the yellow light starts to burn for about 1 day. After that the green lights flash.

I can not acces my MBL. I can’t reset the MBL.

Can somebody help me.

Gr. Bart

Check the manual to see what the different colors for LED mean.
Also try to connect to the dashboard. See manual as well.
Again, check manual to how reset the unit. There are two options.

To find your device IP in order to connect via the dashboard, go to your router and look for the DHCP lease/client/ list/table. If not sure how to do this, refer to your router’s manual.

Sorry i don’t understand the solution.

The yellow lights means that the system is starting.

I can’t make any connection with the MBL. Not via the dashboaord or something else.

My router seems to work fine, i have wifi on my mobile Phone.

Please can somebody help me.

Also i can’t reset the system.

Gr. Bart


Bart_van_Baardwijk did you still have the same error or the support help you?

Because im waiting for the support to help me with the same probleme as you. If I have the solution i’ll write it to you.

I think we need to uptdate the firmware (a hard flash) but i still dont know how to do so.

Thank you

It is most likely that at least one of the problems you have is that your MBL does not have a IP lease from your router. This can happen for a variety of reasons. One of the reasons might be your router. You might have assigned a static IP address in your router or in the MBL dashboard to the MBL. You should reset your router to factory configurations so that you isolate the router as being a potential problem.

Here is the basic troubleshooting process to solve ANY problem with the MBL

  1. Reboot: Unplug the ethernet cable. Wait a minute. Then unplug power supply. The reconnect power supply and ethernet cable at basically the same time. This method fixes little problems like the apache webserver not working or the samba windows server not working.

  2. Reset: using the pinhole on the back. Make sure to hold the pin in for EXACTLY the amount of time specified in the users manual. Too much or too little, and the MBL will not reset. This method works best for internet connectivity problems since it resets the MBL to a dynamic IP address.

  3. Reinstall firmware: if you have access to Dashboard or SSH, then reinstall firmware. To do either of these methods, you need to be able to connect to the MBL over your network. The dashboard method is the cleanest. The SSH method is only if you can’t do it with Dashboard - look for manually firmware upgrade on this forum for details.

  4. Debrick: There are many Guides on this forum how to do this without losing your data.


I still have the problem! I cant make any connection with the MBL. The green lights flash en sometimes the green light stay green.

My router works good, the internetcompany checked the connection.

Please help me.

Point 1/2/3 dont work for me.

How i need to Debrick the system?

There is a guide on this forum for how to debrick. It explains everything.


I have a Book 2T that never got further then a blinking yellow led. Since my wife recycled the package in a hurry I could not send it back, so I bought a similar one.
That device works properly. So I’m very interested to start up the first one. I tried out every possible way from rebooting to direct lines. Next destination is the trash unless someone can apport a solution.
I believe it’s indeed a software failure on the HD.


You need to do the Debrick. Follow the Guide on this forum