Problem with My passport essential SE 1TB


I just bought my passport essential SE 1TB, and this is the story :

  1. firslty i connected my passport essential to my PC (windows vista 32-bit) and it worked perfectly fine

  2. after that, i connected my passport essential to my friend’s Mac. It seems that my passport needed to be reformatted. after that he copied some files to it

  3. now i connected back my passport essential to my PC (where originally it was working) but right now i can’t see the disk appeared in my computer

i check the computer management->storage-> disk manegement, i can see the device but it’s not allocated with drive letter.

when i right click, everything was disabled except “delete volume” and “help”

i tried to installed the latest firmware and ses driver but still failed

anyone could help ? appreciate it so much!

If you formatted the drive for Mac Windows cannot read it.


Hi Joe,

Thanks for your advice. do you have any idea how to format it back in Windows so that i can use it back in my Windows laptop ?

Thank you



Just follow the steps from the link below to format it again for windows.

Thank you. It works!

Btw, I realized there is another 200MB partition (if I’m not wrong this contains the WD default program and user manual etc) which cannot be deleted. So my maximum capacity of my passport essential is 931 GB only. Is this normal ?

Is there any way i can “format” the 200MB section too ? when i right click this section, all options are disabled except “help”

The 931 size is correct. I don’t have a link handy but it’s a math thing. There is no way to get rid of the virtual CD if that’s what you are talking about.