Passport SE 1TB PC MAJOR ISSUE


#1

My external hard drive recently stopped working. I put it in every USB port I had, all of them work, just not with the hard drive. I tried it on other computers and still nothing. It lights up and spins and seems to be working properly. I plugged it in and continued to work with my computer doing other things and in about 10-15 minutes a screen showed up saying that the drive needs to be formatted. I do not want to do this but if it allows me to use the drive again I’ll do it, so I attempted to. I tried every possible combination to format the drive and everytime it says, a second after I hit format that windows is unable to format. I have over 500 GB of information on this drive, I do not wish to lose this information if it can be helped. I looked into the drive itself and have been informed that even if I open up the case the drive will not have any other connection but the mini USB which, seems not to be working. If there is some way that I could simply send the product in and get it fixed and save my information I would prefer that or if there is some way that I could fix it. I uninstalled the drivers several times and i did it again and restarted the computer and all of a sudden it reinstalled correctly allowing me to view my folders. This would be great except that I can’t move the files, I can’t view them, and more than half, that’s over 250GB of info is no longer there, the folders are, just not the files. The space is still taken up also so my 1TB drive has only 300GB left, and for some reason is missing 70GB altogether. So it says I have 300GB of 930GB free.