Problem connecting to the MyCloud server

Tried to set up MyCloud 2TB for the first time yesterday. It is recognised by mobile devices (after installing the app) but not by my Mac. I installed the desktop apps but repeatedly get the message "There was a problem connecting to the server “WDMyCloud.local.” when trying to connect. Am intending to use MyCloud as TimeMachine back up. I can select Public on WDMyCloud as the back up disk but then get the same message after each connection attempt. I’m probably missing something obvious. I’d love to know what.

Have you looked at your routers DHCP table to find the IP address of the My Cloud? I am assuming you haven’t changed to a static IP for the My Cloud.

If you find the IP then you can use that to access the My Cloud.

Thanks. I wouldn’t know how to change to a static IP so assume that’s not an issue. How do I get to the router’s DHCP table and how do I use the IP address of the My Cloud when I have it? Basic questions I’m sure.

I found the IP address but how do I use it? Put it into the browser but server couldn’t be located


Can you ping the device? If you can get the mac address of the Mycloud, put in a reservation and assign a static IP address to it. Servers attached usually work better when outside of DHCP.

Kind regards,


Thanks Bill. I assigned a static IP to the MyCloud but still get the same error message. Not sure where to go from here but thanks for the help.

Hi everyone,
Just wondering if you found a solution to getting My Cloud to work with Time Machine. I have been getting the same message for a year on my mac and cant figure out a solution. Thanks for any help.

I am having the same issue while connecting to WDMyCloud to set up TimeMachine on a Mac. I don’t see a full solution in this thread for the question raised. I realize setting a static IP makes connection more reliable, but the connection dialog box doesn’t ask for an IP address, only Name and Password. Hmmm, this should not be this difficult…
Any ideas?

I too am having this same issue. I’m trying to get my time machine backup bc my hard drive just crashed and I lost everything but now it won’t connect.