PR4100 - Upgrade to OS 5 Makes WD USB Drive Invisible for Backup

Just upgraded one of my PR4100s and now am unable to access the mounted WD 4GB USB Drive that worked yesterday (prior to upgrade) for my simple copy backup.

Chat group made me jump through all the hoops and then wants log files but have no way to upload to the issue file since their file upload system will not accept their own created .zip log file… Chat person started on about all the great new features of 5 but with no backup…

Waiting for issue to be escalated so until then - USB Backup is not available. Expected more from WD. That was why I purchased both the NAS and USB from them.

Suggest you review all topics concerning OS 5 prior to moving forward since the upgrade is apparently a one way trip.

@videoflyer what’s your case number? Can you provide the make, model and format of your USB drive? IE: is it HDD or SSD? Are you doing NAS to USB or USB to NAS backups? Is the USB drive connected to the front or the rear USB port? The system logs will tell us more if your USB drive is inserted at the time of log capture.

I cannot duplicate your issue with 4 TB My Passport (NTFS)

Hi SBrown,

Thanks for offering to help!

Its a PR4100 NAS unit (have 2) and they were both backing up to their own 4TB WD Passports drive sets until I upgraded the one to OS 5. Once the upgrade was completed, I had to install the USB Backup App (since 5 has no apps installed after the update). Nothing has changed other than the OS 5 Upgrade and install of the USB App. (When it did not work I did the usual set of reboot, dismount and reboot and reconnect, try another drive, etc. - nothing changed).

Interaction is very similar to OS 3 but with OS 5 it doesn’t work (select type of backup - NAS to USB, Select Source Folder (selected), Select Destination Folder — and there is nothing to select - the widow is blank). Yet the drive is available:

|USB Device Name|Western_Digital My_Passport_25E2|
|Manufacturer|Western_Digital|
|Model|My_Passport_25E2|
|Serial Number|WX31DB752C6R|
|Firmware Version|4.005|
|Size|4 TB|
|Port|Connected USB port 1|

Even tried as a test to do “USB to NAS” and then the Select Source Folder is blank.

Yet the share is also available:

Share Profile:
|Volume|My_Passport_25E2-1
|Share Name|| Its here but I removed
|Share Description|| Its here but I removed
|Public|| Off
|Oplocks|| On
|Usage|1TB|

These are the same settings as pre-update but the software for the USB Backup does not have the USB resource available even though the system shows the resource wherever it should.

Case number - the person who worked with me online (CHAT) said they were going to send me an email - nothing three hours later so I presume that they did nothing with all the data that I sent them but fortunately I had submitted the previous day as:

Incident Confirmation:
Incident #: 201029-001865

Its very hard to believe that this is not working. How could it have gotten through regression testing?

I have the log file but am not yet comfortable posting in a more public forum but will send if that is the only way…

@videoflyer thanks for the details.
Two more questions.

  1. Do you have the same problem if the USB drive is connected to the Rear USB Ports?
  2. What format is the My Passport? (NTFS, eXFat, HSF+) etc…

Hi SBrown,

Thanks for your continuing efforts.

The drives have never been plugged into the front ports (I only use those for my photo drives) so they are always plugged into the rear ports.

All the drives that are used for the backup sets are MyPassport 25E2 and are formatted NTFS. They all only have one partition. When I dismount and then remount onto my Win10 machine, they mount fine and operate fine.

Here is the samba file from the drive (rename with .xml extension) .smbm - Copy.txt (983 Bytes)

What else can I provide?

Additionally, here are the files that I provided to the CHAT person (who apparently did nothing with them!) as we tried troubleshoot yesterday.


Screenshot 2020-10-29 161353
Screenshot 2020-10-29 161451
Screenshot 2020-10-29 161959

Thanks for the details.
We’re able to duplicate your USB2NAS and NAS2USB backup issue when the USB Share is set to Private. When we switch to Public, the USB drive appears in the list. Issue that been reporting to engineering team.

Thanks for the follow through.

Of course you know the next questions

Can the engineering team provide some estimate on when a fix can be shared and how that will happen? Shall I turn on automatic update or?

Appreciate!

1 Like

Any news mate?