PR4100 does not switch on

Hi - I switched of the PR4100 while I was away. Tried to restart it today and it does not switch on. It tries - the data screen and drive lights flash briefly and I hear the fan but it stops. This repeats itsself a few times and then stops. I tried the power supply in each of the inputs but no luck.

any ideas?


Have you tried another power supply?

Hi, not yet - this happened yesterday evening, so trying to source a replacement.

Follow on question. What is the purpose of two power inputs. Can I connect 2 power supplies?


I tried a new P/S, still the same. Tried 4 sec and 40 sec reset - still the same - assume its bricked. Annoying , I would expect these things to last more than 2.5 years.

I swapped over the RAM modules - same problem. I have removed the RAM and the unit now seems to boot with the LCD showing welcome to WD My cloud PR4100 and the on button flashing blue. However it just sits there and does not seem to progress to full operation.

I tried each of the memory modules in the top slot only and the same happened.

I tried each of the mem modules and the lower slot and the LCD comes on the same for 7 or 8 seconds and switches of them keeps repeating until I pull the power.

My conclusions is the mem modules are OK and the issue is with the lower slot. Though it is a simplistic view.

Thoughts anyone?



I spoke to WD - they were knowledgeable and sympathetic. Even though out of warranty offered to try a warranty replacement. I do not live in Europe so they took that option away. Looks like its a paperweight.