Port Forwarding Not Working?

Hi, I have tried to manually port forward my WD My Cloud with no luck. I have many other devices with successful port forwarding on my network. The only device that is not working is the My Cloud. The screenshots below should be able to describe my problem.

I did also try other ports (because I realise Twonky server uses port 9000) but they too did not work.

Is there an option to allow UDP AND TCP through on those ports on your router , I had to set both to be passed through.

@Wullailhut Hi, are you sure we need both TCP and UDP ? If i set it to use UPnP, the portmap shows that it is using only TCP ports:

I have seen many users reporting that manual port forwarding is working only when they forward the external ports to internal ports on the router (which my router cannot do). However I thought that this wouldn’t be necessary since the NAS asks for external ports when setting up manual port forwarding. So external to internal ports should be handled by the NAS itself.

Do you have external ports mapped to internal ports in the router settings ? Or are you using only the external ports like myself ?


The internal and external ports should be the same as the values set in the manual port option in the Dashboard. Try setting the INT port value to the same as the EXT port value to see if the data is passed correctly to the My Cloud.

Otherwise based on the picture you posted the router would pass port 9091/9444 from the internet to internal ports 80/443. If your My Cloud is configured for ports 9091 and 9444 then the router won’t route the data to the right ports on the My Cloud because its pointing to the wrong ports. Use the same external/internal port numbers that you are using on the My Cloud.

@Bennor I think you are misunderstanding what I was showing in my second post. That is when I set it to auto on my NAS and let UPnP do the forwarding.

I already did exactly what you said in my first post. In that case those entries in the UPnP table do not exist as UPnP is not being used. Remember, I cannot manually forward external ports to internal ones in my router. Only UPnP does that on my router.

While I agree with what you are saying about using only external ports (as I said in my second post) the results disagree with the both of us (well my results at least):

Port forwarding is successful when I use auto option with UPnP and the external port is forwarded to an internal port in router.

Port forwarding is unsuccessful when I manually forward the external ports only.

Does yours work with external ports only ? I.e. no forwarding external to internal ports within router.

I have ports 9080 on the router being directed to 9080 on the mycloud and 9443 on the router being directed to 9443 on the mycloud set up on my router UDP and TCP.

With 9080 and 9443 defined on the Mycloud UI.

What is the make/model of the router you are using?

When I have port forwarding enabled in my broadband provided router along with having the My Cloud configured for manual ports I have no problems with remote access. I either use ports 80/443 or 8080/4443.

Obviously you need to ensure your not trying to forward the same port to multiple devices.

@Bennor I have a Netgear DGN2200. The ports (for example, 9080 and 9081) are not being used by any of my other devices but I still cannot get them to forward correctly.

When I use UPnP, port forwarding is successful. However, if I navigate to http://mypublicIP:externalHTTPPort, I just get a page cannot be found error. Isn’t it supposed to show an Error 404, access not allowed message instead to prove it is actually forwarding correctly ?

Any particular reason why your using UPnP when trying to open up two manual ports through the firewall? What happens if you go to Security > Firewall in the DGN2200 router’s administration screen and add two inbound rules pointing to the My Cloud for the two ports?

I’m not. Right now I’m using UPnP because manual forwarding won’t work. On the NAS you can’t use UPnP and manual at the same time - it’s either auto (UPnP) or manual.

I did (as in my original post). It doesn’t work. It only seems to work if I forward ports 80 and 443. But I don’t like forwarding these ports as I may use them for other services in the future. I’ve tried various other external ports with no luck.

OK just so I understand, you can port forward (within the router) ports 80/443 to the corresponding ports 80/443 on the My Cloud. But if you use any other port numbers the port forwarding fails. Correct? If so what happens if you change only one of the port numbers and not both as a troubleshooting step. So for example port 80/8443 on both the router and the My Cloud. Does it work or does it fail?

I tried another solution that worked also…

Here are the settings on the MyCloud…

Setting the access ports on the MyCloud to 80 and 443.

This is the rules on my router to port forward incoming connections on port 9080 to 80 on the mycloud and incoming connections on port 9443 to 443 on the mycloud.

This is the result on the status page of the mycloud.

Showing the direct connection estrablished.

Using those port forwarding rules means that ‘Auto’ works just as well also , but I like to know and be more in control of what’s happening.

@Bennor That is correct. It’s difficult to test because it’s so glitchy. Normally i have to toggle the remote setting on and off and wait a while before i see the changes.

I tried with 80/8443. The my cloud shows that port forwarding is successful. However, if i try and access the the my cloud using https://publicIP:8443 i don’t get the access denied error like i should. Also, using port test, port 8443 is reported as being closed.

Port 80 is reported as being open and i do get the access denied error when using http://publicIP:80 .

I recently changed my router from AP mode to router mode. On FiOS it requires me to keep their router in the network for TV services. In that mode uPnP on the FIOS router automatically installed the port forwarding and it always worked.

So now with the 2nd router connected with its own subnet and the NAS connected to that LAN it never populates my Asus router with uPnP. I had to manually add them to the firewall. So why is that? I’m using the standard auto mode on the NAS uPnP - I use static IP for the NAS on the new subnet LAN

Depends on where the NAS has it’s IP address allocation… If your main router is on a different sub-net from your own router then it’s really fiddly getting a system on your main Network ( talking to a device on a different sub-net ( for example),

UPnP just doesn’t like working through Sub-nets.

My main router is the FiOS one and the NAS is on the 2nd router LAN subnet. So why doesn’t the NAS auto uPnP work on that subnet? I have it configured as a static IP on the 2nd router subnet. The 2nd router has its WAN IP assigned to the DMZ IP on the FiOS router.