MyCloud - Port Forwarding on BT Hub 3 (w/pics)

I have just bought the My Cloud and have spent the last few days trying to do this port forwarding thingy.

I eventually found a method that work for me, posted here back in 2012 by Bembudo.

Sorry if this is old news and it has been sorted, but i spent over two days trying to get this to work. So I thought id pass on my findings.

This is what I did:

I went into my router and only turned on UPNP and DMZ. Under Advanced Port Forwarding Settings.

I selected the ‘Mycloud’ from the drop down box. Saved and logged out.

I did not set up or open any forwarding ports… Above is all I did.

I opened up the MyCloud dashboard and went into the settings / General and the ‘Configure’ bit of remote access.

Select Manual and left it at the default 80 and 443 and hit save. It did come up as unable to connect on these numbers but that is what i expected.

I then set remote access to OFF.

Then rebooted the MyCloud Device.

Once it had rebooted I went back to the remote access and enabled it… Set to ON.

I then rebooted the device again and it automatically established a port forwarding connection.

 Hope this helps others.

Hi there and welcome to the WD community.

Thanks for sharing this withh the community, hopefully this iwll help other users with a simlar situation.