PlexPy on NAS

Has anyone managed to install https://github.com/drzoidberg33/plexpy on their My Cloud Mirror?

I get

ImportError: /usr/local/modules/python27/lib/python2.7/lib-dynload/_ssl.so: undefined symbol: SSLv2_method

So I assume python isn’t compiled with SSLv2 support. Is there a way to add it? Obviously My Cloud Mirror doesn’t run debian like I believe My Cloud does so there is no easy way to install it is there?

I haven’t try this.

Let’s see if any of the users can share some information about it.

I got the same error when trying to run it but lucky i was able to get it running.

With the latest firmware SSL is broken from what i could find on the net.

What i had to do was install ipkg and install python2.7 and run the script to that path i also had to edit two files for this to work both init.py and config.py py changing the port from the default as for some reason 8181 was in use (not sure what) but from there i ran the script and it works great! I haven’t yet gotten to daemon part and also with ipkg i couldn’t find a way for it to mount the usb containing the ipkg setup automatically to /opt because /etc/fstab is not allowing me to not sure but i may just make an application to fix this but other than that it works.

Hope this helps!

Oh thanks, I haven’t heard of ipkg because, will take a look

Where do I find ipkg? Having trouble locating it other than for Synology

I’ll write up a how to for you give me a few moments :wink:

Ooh thanks, no rush, I’m away for christmas anyway and turned my NAS off before I left home so can’t do it right now anyway

1 Like

No problem it is taking me some time to write up but it will be here sometime soon so check back :wink:

Okay here you go

OptWDMyCloud by Baraka

I would have posted it here but i can’t post more than two images but this should be find

Let me know how it goes :smile:

-Baraka

wow, thanks.

I’ve starred it so I remember to try when I get home

1 Like

No problem, looking forward to seeing how it goes for you, if there is any questions you need answered regarding the how to etc (once you do it) let me know :slight_smile:

Thanks. I am trying this evening so I’ll let you know

1 Like

Thanks, that works perfectly. The reason port 8181 doesn’t work is because it is used by the restsdk-server

1 Like

You are welcome, great to hear it works and thanks for that information on that port :wink:

Here you find a full install instruction plexpy install mycloud Mirror

Trying to install PlexPy on a WD PR4100, My linux skills are not what they used to be… Anyone able to help?