[PACKAGE] Tautulli / PlexPy, adds monitoring, analytics and notifications for your Plex server


#1

Tautulli (used to be Plexpy)

Tautulli is a python based web application for monitoring, analytics and notifications for Plex Media Server.

Official website

WD app download

New link: https://wdcommunity.com
Old link: https://tafelpoowt.stackstorage.com/s/u25bQ7p9swxZXc6

Just install this via the web interface.

Upgrade to Tautulli Beta

If you don’t like the app as it is, here are the instructions for the beta version.

1. Stop Tautulli

cd /shares/Volume_1/Nas_Prog/tautulli
sh stop.sh .    

You may want to backup plexpy.db and config.ini before you go ahead. It’s in the master directory.

cp Tautulli-master/plexpy.db .
cp Tautulli-master/config.ini .

Either you use Entware with automatic updates (2A) or the manual install (2B).

2.A Entware and git

Based on this: https://github.com/Tautulli/Tautulli/wiki/Installation#linux
You need Entware and git.

opkg install git git-http
git clone https://github.com/Tautulli/Tautulli
cd Tautulli
git checkout beta          # or any branch you want e.g. master

Then fix the start script to point to Tautulli instead of Tautulli-master.

sed -i 's/Tautulli-master/Tautulli/' ../start.sh

2.B Manual install without Entware

Download and extract the Tautulli source from github

wget https://github.com/Tautulli/Tautulli/archive/beta.zip --no-check-certificate
unzip beta.zip
cd Tautulli-beta

Fix the start script to point to Tautulli-beta instead of Tautulli-master.

sed -i 's/Tautulli-master/Tautulli-beta/' ../start.sh

3. Start Tautulli

Start plexpy (it’s the old name) but not on port 8181, which is occupied by WD restsdk

python PlexPy.py -p 8282

Now browse to http://fill_in_your_IPaddress:8282 and use your brains.

Notes

Restore config
If you had the old PlexPy package, you can restore your settings and database to Tautulli:

cd /shares/Volume_1/Nas_Prog/plexpy/plexpy-master
cp config.ini ../../tautulli/Tautulli-master
cp plexpy.db ../../tautulli/Tautulli-master

Then uninstall plexpy and restart Tautulli.

Installation failure

Installation may fail for older WD NAS due to an outdated python version

# python --version
Python 2.7.5         

If it is lower, e.g. on EX2100, Tautulli can’t start due to missing HTTPS handlers.
Install Entware package.
Install python (and git while you’re at it)

opkg install python git git-http

Then disable/enable the app in the web interface.


#2

Thank you very much, everything very well explained.
I would like to ask for help. If you could make another bin file with tvheadend (https://github.com/tvheadend/tvheadend). Thanks


#3

Tvheadend is available via Entware and docker. I may try to make a native app but it’s not a priority at the moment.


#4

I got it installed with docker, but when the pr4100 restarts the program does not start automatically.
Do you know if with entware restart with the pr4100?
Thanks


#5

Entware has an /opt/etc/init.d section, so probably it will start automatically.
I know it works for transmission.


#6

Installed the .bin file for my pr4100 and all was working great but I made settings change with local host of 0.0.0.0 to some other IP address which wasn’t valid and now i can no longer login to plexpy. I uninstalled the app then reinstalled it but still refuses to login to myip:8282
Can somebody point me the way… PlexPy has become a handy and necessary monitoring tool…


#7

Did you reboot your box?
If you did and it’s still broken, you could try following steps:

Check if plexpy process is running.

ps | grep [p]lexpy

If it is not, check if an old process pid file is blocking a new process to start. Remove it.

ls /var/run/plexpy.pid
rm /var/run/plexpy.pid

Then restart plexpy via the webgui or with

cd /shares/Volume_1/Nas_Prog/plexpy/
sh start.sh .

#8

Thanks for the reply Tfl… yes after I removed it I restarted the pr4100 then I installed the .bin file and still broke… I will in install Python and poke around with your steps… wish me luck… again thanks


#9

…Back again…still no luck… the ls and the rm commands didn’t work… something is defiantly getting blocked… I am at a loss … Is there way manually change the host back to 0.0.0.0


#10

Without logs I can’t do much.
Is plexpy running?

ps | grep [p]lexpy

If it is, kill it with

kill $(cat /var/run/plexpy.pid)

But probably it isn’t running.
Run it directly and share the output.

cd /shares/Volume_1/Nas_Prog/plexpy/plexpy-master
python ./PlexPy.py --port 8282

CTRL-C to stop (if it would keep running… but I guess it won’t).

You can also check if the port is blocked. Nothing should be running on 8282 before you start plexply.

lsof -i -P -n | grep 8282 | grep LISTEN

#11

@Tfl… thanks so much for your patience… with your help I think I’m close… I ran it directly and was able to see and use plexpy again… yay… but as soon as close my terminal (using putty) its gone. I re-run the command and it’s up and running… I think my restart policy for plexpy is messed… is this policy editable… again thanks for holding my hand …LOL ---- the plexply process is not running…

on my box I did this

cd /shares/Volume_1/Nas_Prog/plexpy/Tautulli-master
python ./PlexPy.py --port 8282

and it ran directly…

**here is a piece of the PlexPy Configuration — is the nolaunch the issue??

Arguments: [’–port’, ‘8282’, ‘–nolaunch’]
Platform: Linux 4.1.13
Python Version: 2.7.5 (default, Oct 14 2014, 15:42:35) [GCC 4.8.2]

another edit–
I ran

docker run --restart=always plexpy
and this changed

Arguments: [’–port’, ‘8282’]
Platform: Linux 4.1.13
Python Version: 2.7.5 (default, Oct 14 2014, 15:42:35) [GCC 4.8.2]

but still no go once I close my terminal… closer maybe

— because I am a new user here, I can’t upload a Plexpy log

more digging when starting plexpy from the command line===

root@Movie-Server root # cd /shares/Volume_1/Nas_Prog/plexpy/
root@Movie-Server plexpy # sh start.sh .
start.sh: cd: line 7: can’t cd to ./plexpy-master
python: can’t open file ‘./PlexPy.py’: [Errno 2] No such file or directory

I don’t have plexpy-master, mine is Tautulli-master… is line 7 my problem and is it editable…


#12

I installed using the bin file for the pr4100 through the web interface it installed and said it was on but clicking on configure takes me to dead end url and using my IP address for the device with 8282 returns nothing what am missing ?

THANKS


#13

@TflBack up and running!! plexpy was looking for plexpy-master but my box had Tautulli-master … so no go… I renamed Tautulli to plexpy and ran the start command… All happy now>>>
Again hats off to you TFL… Thanks for all your help…

@aaplfan – that was happening to mine… i use putty to ssh into my box, login as root and your pass… then do this

cd /shares/Volume_1/Nas_Prog/plexpy/
ls

now do you see plexpy-master or Tautulli-master, if you see Tautulli then you have the same issue I had…

my fix was just to rename my master file by…

mv Tautulli-master plexpy-master
sh start.sh .

go back to browser-- local ip addy:8282

BAM-- all good … just remember any changes you make to your box is on you… Good Luck…


#14

@FM45 That worked for me as well! Thanks for clear instructions and commands!


#15

Oh I see… they recently renamed the project and now the repository as well.
I’ll fix the whole package to use tautulli instead of plexpy.

Thanks for the debugging.


#16

Made a new version for Tautulli and added instructions for data recovery in opening post.


#17

Docker restart on reboot:

So search the tvheadend docker container config

find /var/lib/docker/containers -name hostconfig.json -exec grep -il tvheadend {} \;

Edit the file

vi $(find /var/lib/docker/containers -name hostconfig.json -exec grep -il tvheadend {} \;)

Press / and type Restart to jump to the RestartPolicy.
If it is this:

"RestartPolicy":{"Name":"no","MaximumRetryCount":0}

Press i to enter edit mode and change it to this

"RestartPolicy":{"Name":"on-failure","MaximumRetryCount":3}

Then press ESC and type :wq to save and quit.


[PACKAGE] NZBGet for PR2100/PR4100
#18

TNX for the Update(s)… :+1:


#20

Hello, I have WD app installed on my PR2100 but the only way to refresh the data is to reboot the box, I have tried with both Websocket on and off and its the same, any ideas?


#21

Sorry Martin, that question doesn’t make sense to me.