Plex Remote Access

Last week I set up a new MyCloud Home and set up the Plex server. I can see my files, both in the NAS, and on the apps but the only way I can get the content to play in Plex is through a web browser. When I try playing on an app I get “error occurred while attempting to play this item” on all music and videos, but I can my photographs. I have tried both checking an unchecking available outside local network, it doesn’t change anything I cannot play the content. I was using a Deco9 Mesh wifi and thought that might be an issue so paused the Deco and reactivated the Virgin as a router rather than a modem and the MyCloud Home is now attached to the Virgin router, but still the same issue. I perviously run the Plex Server on a laptop so I am not new to Plex and had no issues when the server ran on the laptop. I am now at my wits end trying to get this to work and cannot work out what is causing the problem. The only thing that I am not familiar with is the connection type of the MyCloud Home, it is Local connection, so don’t know if that would have an impact on Plex and if it does I don’t know what to change it to or even how to change it. Can anyone help with this?

1 Like

Hello,

Please refer to the following KBA article: 3rd Party App: How to Enable and Configure Plex Service on My Cloud Home

Just forget plex as an app or web app.
It simply doesn’t work on a cable network.
It is the most unstable and unreliable application I have ever seen.

Even by their own admission, Plex is saying running their server on ARM model CPUs is a bad idea.

  • Be a supported ARM model

Note : ARM models generally do not support video transcoding at all.

Even Compatible Media May Need Transcoding

There are also situations where transcoding is required even if your media is otherwise compatible with your playback device. This can be the case when:

Hi,

I’m having the same problem, Plex on MyCloud Home, library content shows up from browser but doesn’t show up from Mobile App or Amazon Fire TV.
I reiterate, the problem is only on library content and only from app, from browser everything is ok.

Hi, I haven’t found a solution and don’t know if the fault lies with MyCloud Home or Plex?
The app works on ipads but continues to show a fault on android devices and on Fire TV. I’ve now gave up trying to find a solution as it us obviously not me or how I’ve set anything up. I’ll therefore continue with Plex for the 3 months freebie but will then cancel.