Plex on my cloud ex2 ultra

Hello,

I come to you in desperation

For the last couple of weeks I have been trying to set up plex on my my cloud ex2 ulta. I believe this is possible. I would like it installed on the NAS rather than my laptop so I can access it when the laptop is off view the ps3 app, google chromecast and mobile phones. I plan to use ps3 and chrome cast as players as my tvs are Panasonic which I don’t believe support the plex app.

I have searched a lot and not found an answer. The process that I have followed so far is. Open the WD dashboard and go to app section. Install the plex app which exists there, then select configure. Configure opens the web browser and takes me to the plex log in where I log into my plex account, where I get a screen telling me to ‘To get started streaming your media everywhere, download and install Plex Media Server on the computer or device where you keep your media.’

I have installed the windows based plex application which asks for a restart then takes me back to the same screen asking me to install plex again. Have gone round in circles on this.

I am not sure a windows based installation is what I need but the other option to download for nas only generates a bin file which I am not sure what to do with. Also I was under the impression that plex was already installed on the nas via the dashboard where I selected the configure option.

I am confused and could do with some guidance as I refuse to give up as I am pretty sure what I am aiming for is possible, any advice would be great as I seem to be going around in circles.

Thanks Paul

Sent from Mail for Windows 10

I have Plex installed on a DL2100, a similar NAS as you do and it has always worked fine, so something is amiss on your system.

I am not convinced that Plex is actually installed on your EX2 Ultra, because when I click on Configure in Dashboard, I arrive at my Plex account and see my media library. You, on the other hand, appear to be arriving at the Plex home page, not your account, So, do you have a Plex account? If not, maybe you need to get one, but you likely will get to create one if you get Plex properly installed. So I will go take a look at Plex site for some info about this. I will return here if I find what I need for you.

I need to know the steps taken to initially install Plex on your EX2 and what steps did you take?. For example did you receive a file in your downloads folder indicating it is for plex and for your ex2 (sort your download folder by date with latest downloads first) and see if a file is there.

If you have it, I will tell you how to install it. Wait for my instructions.

BTW when I was at the Plex site I had a new version to download and install for my DL2100. It is easy, but also a bit tricky.

The update file I downloaded is named WDMyCloudDL2100_plexmediaserver_11134803-c40bba82e.bin

A file for your EX2 has a similar name.

Also, you will want to UNINSTALL the Plex you have installed in your PC. Do you know how to uninstall a Windows program?

Hi Mike, thanks for coming back, really appreciated.

I have a plex account user name paul.gauci

I have uninstalled the windows version of plex as instructed via settings apps etc

My steps of installing plex on the nas are covered in screen shot uploads 3 and 4. Via the pre loaded app in the WD dashboard apps section.

4 - PLEX INSTALLATION FORM NAS OPTIONS

The result of pressing the configure button against the installed app in the WD dashboard is shown in screen shot upload 5.5 - PLEX INSTALLED FROM NAS OPTION CONFIGURE PRESSED

I have downloaded what I believe to be the nas version of the software (bin file) from the plex web app. Options followed covered in screen shot upload 22-PLEX FOR NAS DOWNLOAD FROM PLEX WEBSITE the bin file is called
WDMyCloudEX2_plexmediaserver_11134803-c40bba82e

Please let me know how I should proceed.

I really appreciate your help.

Thanks Paul

Paul,

Thanks for the screen shots they are useful and helped me see a problem. You said you have an EX2 Ultra, but you appear to have downloaded the EX2 version. The Ultra version is shown lower down the list You need to download the Ultra version if you truly have an Ultra.

Hopefully no harm is done and since you have not yet installed the download I believe you can just start over in Dashboard. When you get to the Add an APP and the Plex list of servers appears, go down list to the Ultra and download that one. Who knows if it is same app as the one you downloaded before, but likely has ultra in the file name.

So do this first, and confirm the downloaded file name and tell me what it is, and then we are ready to install. When you return with a new message I will tell you what to do next. We are almost there…

Hi Mike
Thanks for this

Its an ultra.I have downloaded the file which is called MyCloudEX2Ultra_plexmediaserver_11134803-c40bba82e

Looking forward to hearing how to install.

Thanks Paul

Paul,

It all appears good to go, so let’s go . . .

Go into the My Cloud Dashboard and open the Apps tab
Notice in upper left area the blue box with App Store as its label… Directly under the blue box, it says “Install an app manually” in small, light blue type. Click on that statement and a window will open waiting for you to go find the file you have downloaded for the plex media server for your ultra.

Navigate to where it is, click once to highlight it, look in lower right of same window to confirm the selection by clicking Open button. It will now begin the actual install of Plex for your particular device.

You will see a notice it is installing and in less than a minute it will tell you installation is complete.
Next, now you can go into Plex under installed Apps and see it is turned ON and you can click on Configure to open the Plex main page and watch it compiling your Plex database from files on your NAS. If you have a lot of folders and files on NAS this can take a while.for the compiling to finish, so give your self plenty of time for this install.

Lots of tabs to explore, and Plex has pre-set the defaults. I did not change a thing at first until I was sure I knew my way around and then I hardly changed a thing, Live with it a few weeks as it is set up.

You will see lots of requests to buy subscriptions,passes, etc. I have not bought any Plex goodies from Plex Although, much later I bought iOS apps to use it on those devices. Resist buying anything until you are sure you need it and understand what it can do for you.

OK, I have proof read this discussion enough, so get it to happen for you, and let me know how it all goes. I have more to add, but this is plenty for now.

BTW, I am in the US west coast area. Where are you located?

Hi Mike,

Thanks for the advice, I have followed your instructions and unfortunately the same error as per screen shot app installed successfully and configure button pressed and greeted with this screen.

I am lost I need guidance.
I am in Aberdeen Scotland.

Best regards,
Paul

Paul,
Sorry to hear this.

On your path from start to install to the last screen shot did you notice anything “unusual” such as disconcerting messages, etc?

If install went well enough until the last screen, Plex obviously doesn’t know you installed it. The “good news” is Plex is offering you the opportunity to download it from the list of NAS Platforms, so I suggest you click on the orange Download button and you will kijely see the list of WD My Clouds, and select the one for your EX2 ultra. It just may install it so pay attention to questions it may ask you, etc. This may do the trick.

Keep me posted, it is 5pm here so I have plenty of time.The instructions I gave you are for updating, but they should have worked.

Hi Mike,

Nothing unusual during install. Just an updating message box then confirmation of successful install of plex via the manual install apps section of the WD dash. I have selected the download and repeated the WD EX2 ultra download. This time copied the bin file to the public folder of my nas (just in case this made a difference. Uninstalled the plex app via the dash board and reinstalled and hit configure again which takes me back to the screen shown in the screen shot in my last post.
Any ideas? I am tempted to try this from another laptop. I factory rebooted the nas last week so pretty sure its set to factory defaults.
Thanks and best regards,Paul

Paul,It is now midnight here, I am up and working on my reply, so stick around for it if you can. Give me until the half hour to get it done.
BTW, THIS NOT GOOD NEWS,

OK, so the first install was successful, (good) but it still did not work (bad) The placing the update file in Public likely did not help or hurt. But, next time just leave it in the download folder.

Uninstall Plex may be a good idea, but clicking on Uninstall does not work as I found out last month,so I sent out a call for help and a regular user helped me out. He sent me me this WD link so give it a try:

Give install another try again, and let me know how it goes.

PS, as I later discovered my problem was not with Plex so I did not do the uninstall (reset) so I have no experience doing so.

Thanks very much Mike, I appreciate all your help and time put into trying to solve this I will try the uninstall and reinstall from the download folder and let you know how it goes.

1 Like

I have my fingers crossed for you. This whole thing has gotten too weird

Paul,

Any updates? Any luck?

Maybe I missed it but did you do the regular factory reset, or the 40 second reset?

I was having somewhat similar issue, but also was not able to get into the dashboard from my EX2 Ultra. I followed the steps for the 40 second reset as I had poorly attempted to change the name of the device and subsequently (a day later) forgot what I changed it to!!!

After the 40 second reset, I was able to get in and it finally recognized the media in Plex.

Hope you have had some luck.

Jason

Hi,

I would like to install the Plex server on My Cloud EX2 Ultra. There is no Plex in the APPS tab. When I give a manual installation I can not confirm conditions from WD :confused:

Could somebody help me?

There is likely instructions in the WD knowledge base database for how to d/l Plex for YOUR particular My Cloud model. It will likely tell you to go to plex.tv download section, find the file to d/l for your EX2 Ultra, and install it manually.

That’s the problem. If I install manually, a window will appear to confirm the conditions. The “Accept” button can not be pressed. I will push him and nothing happens. Unable to install a manually downloaded file.

The previous guy Paul I tried to help had similar issue. and I presume he gave up. I would contact WD Support directly for assistance…