Plex on my cloud ex2 ultra

Hi mik27oct

Man do I wish that Paul had responded. I’d read line by line thinking this is it… this is the solution!

I am having the identical issue (only from a Mac). It sounds crazy and is doing my head in having to go around in this eternal loop. I’m very technical, am new to NAS EX2 Ultra and have no plausible explanation.

The latest install file for EX2 Ultra being PlexMediaServer-1.15.1.791-8bec0f76c-MyCloudEX2Ultra.bin sent me back int this loop.

Plex has no problem finding other servers on my home network. I’m following the instructions you posted about how to reset the Plex database - it’s taking forever…While I am waiting it’s worth nothing this is a second hand drive and I believe the previous owner used it for Plex. So if this solve’s it maybe this was the case for Paul too. Yes I did the 40 second factory reset prior too.

Anyway, it took nearly 3minutes ‘updating’ before I had to attempt uninstalling with run turned off. Second time round uninstalling it’s worked instantly. Have added the bin file manually and… no luck still.

There has to be some sort of compatibility issue between EX2 Ultra and Plex?

Regards,
Geordie

So I went to bed last night and realised that it was network related. The NAS was connected to the network via my Mac rather than being plugged directly into the network.

Problem solved :smiley:

1 Like

Hello,

I also faced the EXACT same issue on my WD My Cloud EX2 Ultra after installing plex, it went straight to :
192.168.2.150:32400/web/index.html, where it kept looking for the server and could not find it.
When this happened, i was accessing this local ip address from a remote location, wherein the port 32400 was forwarded to my EX2 Ultra.
So, today, i went physically to this location where EX2 ultra is installed, connected to that network directly from laptop. Went to WD MY Cloud web management page and when i clicked on the “Configure” button from the “Apps” tab, for Plex Media Server, it went to the following URL first :
192.168.2.150/plexmediaserver/index.php
So, when i was trying to “Configure” this server remotely, and the port 80 was not forwarded to the EX2 Ultra IP address, this page was not accessed at all, and the web browser directly went to the PLEX Media management page which is :
192.168.2.150:32400/web/index.html without configuring the server first.
So it turns out that this was a network issue due to the previous Server configuration URL not being accessible due to port 80 not being forwarded to the EX2 ultra page.
I’m assuming that the issue was same for Paul, and since nobody replied with a solution here, i decided to sign up and post it!

       You're welcome if this solution works out for you! :)

Thanks folks for the helpful follow up comments.

Hi. First post here. I have an EX2 Ultra and have installed the PLEX that the unit steers you towards, to install, but I have a problem. When setting up, and I DO have a PLEX account registered, I can get as far as selecting the folders where my media is stored. However when I click the ‘next’ button on the screen, I get a message that says ‘YOUR CHANGES COULD NOT BE SAVED’
I this a PLEX problem or one with the WD ?
Could someone advise what priviliges the EX2 should adopt to facilitate this operation? I’m wondering if its a ‘share’ issue on the EX2 rather than with PLEX. Hope this makes sense to anyone reading.

Guys, am facing the same exact issue as Tom_D, how was this resolved?

Fellows. I dealt with this issue for weeks / months. WD support was no help whatsoever. Here’s a weird solution that works for me. I’m not sure why.

Hello,

I have come to this topic and read to the end because the same thing happened to me as to Paul. In view of the screenshots of him in my case it was the same effect.
I have followed Mike’s advice by enabling the SSHD and removing the PLEX folders.
Now PLEX works with my movies again.
I have a WD MY CLOUD EX2 Ultra with OS5.
Curiously, the problem has arisen in these days and when launching the PLEX server again and in its assisted configuration it has shown me these screens referring to changes as of April 22. Today is April 25.

I honestly don’t understand why you have this problem. I am using the best Synology for Plex software for two months now, and I never had a problem. I had connected this device to my TV, and PS4 and everything works smoothly. I will advise you to call the company from where you bought your Nas device, maybe they have a solution to this problem. Honestly, I don’t see any other options here. Keep us posted, mate. I am curious why you are having this problem. In case you need any help feel free to text me.*