PLEX? How do you set it up os ON5?

I thought I give PLEX a try. I install PLEX. Click configure, and it takes me to the PLEX website. There it says I have no media. I created a Share, put my movies in there and… Plex says there is no media, install PLEX. So I download PLEX, reinstall it on my EX2 Ultra and click configure… its an endless loop of nothing.

Where do I set this up? It’s the most frustrating thing I’ve ever tried. Please point me in the right direction.

You should be able to configure your library somewhere like movies, click on the 3 dots and manage/settings and then point toward your library in shares/yourfolderforplexmovies

I tried, I’m too stupid to get this going.

If I click on MycloudEx2 on config, it takes me to the Plex site. I can click on “Your Media”, that will take me to a link where I can download the software for MyCloud Ex2. I remember those … and you could configure that from there, but this is all… not the same anymore. There is nowhere on Plex s website to link to my device. They offer me all their services I can buy.

Com’ on ! Dont be so harsh ! :slight_smile:

In a web browser, type “theIP_of_your_mycloud:32400” to access Plex on your intranet.
Then, log in and access to your settings (the wrench at top right of the screen).

Now, on the left panel, make sure your Ex2 is selected (green check next to it when you click on the litle arrow) and then scroll down to library at the very bottom of the left panel.

Here you’ll be able to perform modification on your library, you can click (at top right) on a button named something like add a library.

You have to set the TYPE (movie, series, etc) and then click on the left side add a folder or next.

Thank you for your reply. I’m really trying. this is what I get. There is no place where I can select my device. (I’m logged into my ex2) I tried all the settings and there is no place to select a library, a folder, a device, etc. I tried this with the Plex that installs itself from the Ex2 and the one I downloaded from Plex site directly.

how about here ??

Does not exist on my version. I’ll try to install the version that I download from Plex once again.

New version installed. Still the same. First screen when I log in is this.

Then I click on the wrench and I get to this.

Whether I’m on my device or logged onto Plex website it displays the same info. Nowhere is my EX2 visible. I setup Plex on my Samsung TV. I entered the local IP address and it says it cannot connect/not available.

I don’t think the Plex server is starting. When I turn off Plex and turn it back on, at least the TV tries to connect but then I get IP;32400 is currently unavailable.

For plex server that is installed on your NAS you need to go to or the address for you nas managment page with :32400 at the end of the name but before the first /. From that webpage you should be able to link it to your Plex account and add media.

It looks like you have installed the Plex Server on both the NAS and your Mac rather than just the EX. Uninstall it from your Mac and Just use the Plex Media Player on your Mac.

Can you show us the page you get when you click “Configure” from the NAS install page?

Your plex server is not yet bound to your plex account…

I don’t have the Plex installed on my Mac. It’s only installed on the NAS.As you can see from my screenshot above, the ip is So I am on my EX2 Ultra NAS. The first screenshot is where it takes me when I hit the configure button. The second screenshot is where it takes me when I click on the wrench.

Yes, but I cannot get to the point where I bind it. I installed the latest software, not the one the NAS downloads but the one I downloaded manually from the PLEX site for the Ex2 Ultra. It seems to be a newer version. Regardless, both act and look the same way.

There is no media server installed other than the one on the NAS. It’s interesting that even the TV cannot find it when directing it to the IP address for the NAS

Well, the PLEX installed on your NAS has to be CLAIMED by the PLEX service (online or something) ; so it is bound ! You cannot use the service without binding the plex media server installed locally witrh the distant service (

So it totally expected for it not to be seen by any other media :wink:

Thats the problem. locally or at Plex, there is no option where I can claim my Plex service/NAS.

You sure to be login on the same plex account on both side ? :stuck_out_tongue:

Yeah, I tried everything. Just doesn’t work. I gave up and went with Twonky. It ■■■■■, but it works, which is better than nothing at all.

When I read your answer, I thought to myself “that’s it!!!”
I had the exact issues dale described, and was banging my head against the wall. I don’t know how or why, but I had somehow created 2 Plex accounts and was signed into the wrong one. (I’ll delete the duplicate soon).
Once I signed in to the one I used for the MyCloud, it was fine. And now running on the Firestick. Which will let me take my movie library with me when I visit a friend’s house.

Funny how such a frustrating issue can have such a simple answer. Be Well!