Please help me to get the data back

The wife has a WD elements 1023 E101559 WDBABV0010BBK-00 1TB portable hard drive. She has 600G important SAS data on it, which did not be backed up from Nov 2014. Last Friday, it suddenly stop working.

We plugged it on 4 different PCs. All shows up as CD drive. Also, the WD drive cannot be found in Ubuntu too. The hard drive can be seen in Disk Management, but shows as not initialized and unallocated. When I try to initialize it as MBR which suggested by Disk Management, it shows up “the media is written Protected”.

I tested it in WD Data LifeGuard Diagnostics. It passed Quick Test and everything looks good in the report(WD drive spins all the 5 mins test time). However, it could not pass Extended Test at all. It showed too many bad sectors.

Then, I used DiskGenius and HDTune to test the bad sectors. Found more than 100K bad sectors and only two good sectors, one at the beginning and one at the end.

To fix the write protection, first, I tried  “Thumbscrew” in registry. Since there is no “Storage Device Policies” in the registry, I created “WriteProtect” and assigned value at 0, and it did not work. Then, I used DISKPART in CMD.exe and use command “attributes disk clear readonly” and it failed too.

Since there is no drive letter for the WD drive, I cannot use chkdsk in CMD . Considering the data on it,  I do not want to quick format it and then give it a drive letter. So I tried to use HDD Regenerator to fix the physical bad sectors. It told me “19: drive is not ready” . Looks like all the sectors are bad and cannot fix them at all. Also, I tried use DiskGenius to fix logic bad sectors and still failed.

I tried to use some data recover software. First, I did an image copy of the WD drive and tried to use the copy to recover the data, so I do not further damage the original data. In the whole process when I used R-Drive Image.exe, the WD drive only moved at the beginning and kept silent in the very long time. Although it really created a 4G image file (the data on WD should be closed to 600G) in the end after I chose “ignore bad sector” in the options, I doubt it really copy any useful data from WD drive. So I had to use GetMyDataBack and DiskGenius to recover data from the WD drive directly. What I got is only bad sectors information.

I googled WD elements 1023, and found some people have similar problems. Such as, http://www.techsupportforum.com/forums/f149/wd-elements-1023-external-hard-drive-unaccessible-557790.html. Some people think the problem maybe is not with the Hard Drive. It is with the Printed Circuit Board. However, my drive does spin and light up. It looks the PCB is ok. Even I want to give a try to buy a used same drive for swapping PCB, I am afraid to change the bios chip on PCB, since my hot gun are too big to melt and take off the tiny chip.

Do I need to test the PCB by a multimeter? Do I have other options except for opening the driver to recover data? How much normally they charge for a 1T WD drive? Any recommended data recovery company? Thank you!

Hi Sambingny, welcome to the WD Community. Sorry to hear you cannot access your files. In your case I would try to contact WD support before trying anything else, a lot data recovery cases are beyong do it yourself repairs and you seem that have already tried most of the common steps. On the WD support page you can also find several data recovery partners, some of them can offer a free evaluation of your drive. 

http://support.wdc.com/country/index.asp

http://support.wdc.com/recovery/index.asp?wdc_lang=en

Yup! 30+ years of experience with recovery and HDD says you need to take the disk to a professional lab.

seems like you already did a lot to exhaust the drive… but to undestand why your drive reports so many bad sectors I would suggest checking out this blog post or watching this:

too many bad secotors.jpg