WD Elements Hard Drive Not Accessible

I got my WD Elements 2 TB hard drive about 6 months ago as a gift because my computer was down to literal MB, and as a photographer that posed a problem. 

When I got it I moved over almost all of my pictures with the exception of a couple folders, and files that I put on my computer after initially getting it and hadn’t gotten to moving over.

Now, after 6 short months, I can’t access it. When I plugged it in previously it showed up as “Elements”. 

After a few days 2 weeks ago of files corrupting randomly (which I dismissed for whatever reason) it now it shows up as “Local Disk (G:)”. If I try to click on it and open it then it makes “My Computer” unresponsive and in the end it closes. No folders show up and I can’t so much as see anything on my drive. It caused both my older PC and by boyfriend’s brand new, fast, and completely responsive PC to have problems opening programs, starting up, and shutting down. 

It is still under warranty, and I’d like to send it into WD to get a replacement but I need the photos and fies off of it. I don’t have a lot of money to spend on sending it to a big company to get the information off of it, but I don’t know what I can do since I’m unable to access any of it off of any computer. 

According to  **http://community.wd.com/t5/External-Drives-for-PC/FAQ-External-hard-drive-no-longer-shows-up-in-My-Computer-and/td-p/133426 **my hard drive has failed. It tries to connect, the lights blink and the disk spins. We’ve tried new power and usb cables. 

Any help or advice would be extremely appreciated!

The drive sounds like it is corrupt. Try TestDisk http://www.cgsecurity.org/wiki/TestDisk . It could also be malware. Have you tried scanning the drive?


I know that sense of dread, especially regarding pictures. If Joe’s suggestion doesn’t get you anywhere, you can try Hirens Boot CD.


It is several hundred MB of freeware utilities, packaged with three different bootable operating systems. There are convenient menu systems for selecting boot modes, and for different utilities. I had particular success with a failed internal drive by booting into the Linux default with Gparted. Linux was not made unstable by the flaky drive the way Windows was, and I was able to copy more than 500 GB of photo files, plus other things, from the drive.

Granted, this was an internal drive on a direct SATA connection, but the Linux Live boot has USB loaded, so you should be able to access your Elements unit.

If this does not work for you, here is a short video showing how to disassemble the case and extract the drive. (This probably voids the warranty. You have to weigh the value of possibly getting your pictures back versus POSSIBLY not being able to RMA the drive.)


The tools are a couple of small screwdrivers and a couple of plastic cards like credit cards. Once it is out of the case, you can hook it up to a SATA port directly (assuming you have a desktop machine. This also supposes that you have a functional drive to use as a destination for recovered files.

The 2 TB drive in this video turns out to be the very same model which I recovered data from: a WD Green EARS drive.

I hope you can access your data via USB. If you have to take more involved measures I will be glad to offer whatever assistance my experience in this area permits.