Playback Issues with M2TS, MPG, MPEG, and TS video files containing Dolby, DTS, and PCM

WD Announcement for WD TV Live Hub Media Center or WD TV Live Streaming Media Player:

There is an issue parsing the file header on file types M2TS, MPG, MPEG, and TS video files containing Dolby, DTS, and PCM (above 2 channels).  These files may display a “Not Supported” error message, or the files may play back without audio.

This issue is specific to M2TS, MPG, MPEG, and TS files. You can resolve this issue by re-encoding the video to use a different container type.  However, we are currently working to resolve this issue as soon as possible in a future release.


Bill, THANK YOU for this announcement.   

Good to know that WD’s definitely found the issue.

While im wiating for this fix, does it effect all versions of firmware or just the newest?

Just the newest (1.04.12) and unfortunately we can’t roll back to the older one either so be warned!

Heres hoping its not going to be 2 months before the next release - most of my movie collection doesn’t work as a result of this bug :frowning: :frowning:

Please hurry and fix or provide an older firmware we can use in the meantime WD! - thanks

Diito…roll back or fix!

Still waiting… :frowning:

Same here…  I dont use the services in it so with the new firmware mine is just a paper weight :(  I may return mine and buy a new one so it has the older firmware on it.

I just purchased 2 WD TV Live’s… I was very happy with them until I upgraded the firmware to 1.04.12.

My two WD TV Live’s are only 3 weeks old… But I’m already tired have to reset them them every other time I try to play a video file.

I’ve always been more than happy with WD products… but these will go back to the retailer if this is not fixed before my 30 day return window is up…

Just expressing my frustration.

Still waiting 3 weeks later…

At least have the courtesy to give us a firmware version we can roll back to,to get around this issue!!! :manfrustrated:

theres no way I’m going to spend years re-encoding over 4TB’s of files because you introduced a bug in the latest firmware…

Yeah, that’s good…  Tell them to stop finishing up the next release in order to start working on a rollback firmware.  That makes a lot of sense…

1 Like

Clever thinking batman - Like I’d really ask for that.

All they have to do is give us a firmware older than the previous one instead of taking them all off the website…

Well, if you’re REALLY desperate, and don’t care taking a risk of bricking your WDTV (or whatever undisclosed issue rolling back the firmware caused in some instances), you can download the previous firmware from here:


Once you download it, unpack the contents of the zip file, and open the wdtvlivegen3.ver file with Notepad to change the following line:

Original: VERSION=‘1.03.10’

Changed: VERSION=‘2.03.10’

With that, you’ll fool the WDTV into installing this older firmware as if it were newer.

Once you did the former, act as if you downloaded the file from the roll back page, and follow the rest of the instructions in there:

Remember that you’re doing this at your own risk. However, some people who previously downgraded their firmware have reported no problems at all. If you do downgrade your firmware you may want to reset your device, in case of any issues.

EDIT: Changing the VERSION line in the .ver file is exactly what WDC does with its roll back codes. You can verify this by comparing the file here (regular 2.08.13 firmware for the WDTV Live Hub) with the one here here (roll back code for the same firmware). Only that line in the .ver file is changed between the two ZIP files.

1 Like

[edit] I’ve deleted my post. My comment had nothing to do with this issue. [/edit]

Has anybody rolled back to 1.03.10 and notice any difference (mainly stutter problems) with later firmware? Many people asked for a rollback to 1.03.10 and now that it’s given I see no reply/feedback. 

I updated all of my WD TV Live Streaming players to the newest firmware release 1.06.04, but I am still experiencing periodic lockups while playing MPEG / M2TS videos with multiple channel audio.  When you exit out of the frozen movie back to the movie list it shows the audio as [UNKNOWN] and then you receive the message that you cannot play this media, etc. etc.   When you force a hardware reboot you can play the movie again until the same error and lockup happens again.  Is this still being looked at or in the process of being fixed?

This was supposed to have been fixed.  Have you checked the firmware thread for this update to see if anyone else is having the issue?  Also, post how you’re running your sound, and with what devices.  Have you tried, for testing sake, connecting composite to your tv and seeing if the file plays without locking up?  What video and audio encodes are you using with the container?  This way if I need to point this somewhere, I’ll have some more info.

Here is the rundown as best as I can put it … because I have already packaged and put in for return the (4) units that I purchased after attempting each firmware from the original on up and went through replacements already from Amazon which did the exact same thing …

I previously had two other units in the house, a Viewsonic VMP70 (bare minimum) and a decent Patriot Media Box Office (bare bones as well).  Each one of these played (any) of my .MPEG, MKV, MT2S files without any problem whatsoever. 

Upon hooking up the WD Live Streaming I immediately updated the firmware and it looked beautiful.  Keep in mind that I’m doing this on 2 TV’s at my house and 2 at another (they were using Viewsonic VMP70’s for over a year)… I went and hit the play button on a random movie … worked great and started playing.  Then I hit the stop button and went back to the movie list and selected another movie to play, say a MKV one.  Played fine.  Hit the stop button and went to play another MPEG movie (all of these are multi-channel) and then uh-oh.  No Audio.  The video keeps playing for about 20 seconds and then it goes black.  The WD 2.0TB external drive connected to the player is no longer flashing either or responding. 

I hit the (Home) button or (Back) button, which take me out of the movie.  Now here is the worst part.  Anytime I try to select a totally different movie; be it a MKV or MPEG or anything it says that the format of the movie is not supported and I need to check the manual for reference.

At first I thought this was a simple hardware glitch and I just got very unlucky because I’ve played all of these movies on devices made years ago and they all work fine.  What shocked me is that this same problem occurs on every single WD TV Live Streaming that I purchased.  EACH ONE.  Sometimes I get lucky and they will play 3 or 4 random movies when I’m using the ( >>| ) command, etc. but sooner or later it happens again and requires a full reset.

Believe me, I’ve tried two different WD 2.0TB External drives and a Samsung 2.0TB drive just to make sure and used a total of (5) different WD Live Streaming.  I even backed all the way down to the original firmware just to see what would happen and it still did the exact same thing.

To answer some of your technical questions, I had all of these devices hooked up to HDMI to a variety of different TV’s in two different households.  No I didn’t use Composite because alot of these TV’s are mounted on the wall and I don’t have those cables running to them.  I tried turning off and on the media library, internet, remote, with no luck either.  I did notice that when this problem occurs that the audio says [Unknown] when you are in the preview page, when it showed up just fine a few minutes prior.  Others on the forums had mentioned rolling the firmware back, way back, would solve the problem with the mult-channel MPEG files locking up, but I can tell you after doing TONS of testing with your devices that this does not work. Period.

The moment that I re-hook up the Patriot Media Box Office to the HDD, I can play each one of the movies back to back and skip to my hearts content between them without a single error or even a slight audio glitch.  Believe me, I make sure that when I package the movies they play without error or I start all over again.  I’m sorry that this has happened because I wanted to change out all of my units, plus my families units, which would have totalled around 9+ after it was all said and done, but after this I absolutely could not go further. 

Sorry, that it didn’t work out for you.  It might have been interesting to see what the codecs were for both the audio and video on your files, but I can understand the frustration, when you have something already setup that works, and it doesn’t on another device.  If you ever want to revisit this issue, it might be important to see what the codecs were on the file containers.

The “unsupported” for _ all _ subsequent files sure sounds symptomatic of playing a file that the player thinks is supported, but actually isn’t.

The chip tends to get “confused” and “stuck” and power needs to be removed from it to restore normal functioning.