Passport Ultra - reformated to use with Mac but now vanishes!

sorry if this has already been answered anywhere, but I couldn’t find it.

Bought a new passport ultra and followed the instructions at Knowledge Base answer 3865 (as advised in user guide) to reformat for use with Mac. Also downloaded Mac utilities and securities installers - and ran them.

Now, when I plug in the drive, it appears in the left menu for about 2 seconds, then vanishes - and can’t be accessed - what do I do to rescue this? any ideas?

thanks in advance!


Hi there,

Have you tried uninstalling the drive utilities to see if by doing this the drive stops diconnecting? Hope this helps.


thanks for the suggestion - will try that tonight. how would I then reinstall the drive utilities without losing the drive again, as I assume these are needed? Also - the guidance doc mentions restoring the “disk image”. All I could find in the downloads were the “drive utilities” and the “security utilities” - am I missing something?

Incidentally - I installed the utilities installer software into the “applications” area on my MacBook - assuming that it will then install the correct utilities onto the “my passport” drive. Is this correct?  

sorry if these are really dim questions - never used an external drive before  . . .

Any success? I just bought a 2TB Ultra, reformatted it to Mac, and now have the exact same problem with the Ultra connecting for a few seconds and then vanishing.

Any guidance on this would be greatly appreciated.

Didn’t work - no idea how I get the thing to work at all - shows up briefly with the name I gave it when I first set it up but then vanishes :-((

I too am suffering from this. I actually bought a new drive because I figured the one I had was busted, and I get the same exact problem…


it seems I’ve got a similar issue.
I’ve bought a “My passport ULTRA 1Tb” to be used on both win and Mac, formatted in exFAT.
Well, when plugged into MAC I can read, copy and whatever but after 15-30 min it gives an error message and unplugs.
If I plug again it stays for 2-5 sec and then disconnects.
any solution?

I deleted the utilities and did not re-install. I restarted and my drive reappears! Awesome suggestion, thanks!

yeah! It worked fine for me as well! thanks