WD My Passport Ultra no longer showing up on my Mac

My WD Passport Ultra was working fine on both my Mac and my old Windows laptop but now isn’t being recognised by my Mac. I tried to connect it for several days with no luck, then suddenly it recognised it and I was able to access my files again. Tried again next day and it’s not being not recognised again Can anyone offer any suggestions please – other than reformatting it. I haven’t backed it up because it is my back-up!

Thanks in advance, Toni.


I suggest that you start backing up this drive to have a second backup. It’s always best to have two+ copies of the data on different locations.
Which file system (format) did you use for this drive in order to use it on both Operating Systems?


Thanks for your response. I didn’t actually format it - just plugged it in and tested it on my New MacBook Air then copied files from my old Sony Vaio onto it, transferred some of them into my Mac and left the rest in the drive. Used it since several times on the Mac, but suddenly it wasn’t recognised.

Tried again tonight and still no recognition on my Mac but opened straight away on my Vaio with all files intact and it said it was formatted to FAT32.