Passport for Mac drops connection (Time Machine)

I have a WD My Passport for Mac (All black) that I’m using for my Time Machine backup. iMac running Sierra version 10.12.5. The drive shows up on the desktop (yellow icon). Later, it will change to a green icon with the circle emblem, and I will get a notification that the Time Machine backup failed. I have to force eject the drive, then reconnect it to get it back up and ‘connected’. This repeats all the time.

I have tried removing the utility and I’ve also run the utility that says everything on the drive is okay.

I’m guessing it may occur when the computer sleeps and I wake it up…

Would appreciate a solution! Thanks!

Can you connect the drive with a different cable or try the drive on a different computer? You can click on the link below and test the unit for defects.

Thank you. We are away from home for the next week. I will try this when we return and let you know the result.

I switched cables. Same result.

Here are a couple of screen grabs of the dialogue boxes I get…

1 Like

Same problem after Mac goes to sleep.
Unable to complete backup. An error occurred while creating the backup folder