On MAC: “WDMyCloudMirror” can’t be opened because the original item can’t be found

I successfully set up my new My Could Mirror on my network and have WD Sync working successfully from my MacBook Pro 2013 running Sierra. During the setup process the drive became visible within Finder under “Shared” as “WDMyCloudMirror”. And at first I could successfully connect through this shared drive link.

However if my Mac goes into suspend by closing the lid for some short period of time, the next time I open the lid and try to connect to the MCM through this shared link in Finder it cannot connect reporting…
"“WDMyCloudMirror” can’t be opened because the original item can’t be found."

The MCM is however available through the “My Cloud” folder shortcut placed on the desktop when setting up WD Sync and the MCM dashboard is available over the web interface. The unit also reports it is functioning correctly and the Cloud Service “Connected” with “Port forwarding connection established.”

So in short - there is no problem with my MCM and it running as it should do SFAIK.

If I continue to use my Mac then the afore mentioned and somewhat problematic Finder share becomes active again. All by itself! And remains active so long as I continue to use my MBP without letting it go into suspend for too long. (exactly how long I haven’t quite worked out yet.

I don’t want to have to wait for an hour or so for the Mac Finder Shared drive link to become active. I’d like it to be active immediately upon opening my MBP.

Does anyone know why this is happening and how I might fix it?

Appreciate any help or advice.

Hello,

I recommend you email support for assistance with this issue.

OK thanks.