OK to make things clear


#1

Hi all,

ok after reading a million of topics through the net Im too confused to find a 100% answer for this mkv file compression issue, DTS sound issue etc…

I have a WD HD TV device and a mkv file. The file can be played BUT I dont hear sound.

So what is this issue related to? Is it because the WD HD TV cannot downstream DTS to AC3? Or is it because of the header compression? Or is it because of the DTS header compression? Or is all the same?

I read about many applications fixing a mkv file. But which one do I use when I try to get sound through HDMI?

I read that the WDHDTV can handle these files and its because of the header compression. But then I read something else that the player would not even start playing the file when it has that header compression.

So I got that tool mkWDclean. Is that for the AC3 issue or for the bad header compression issue?!

Will there be a fix soon or do we all complain and nobody listens?

Cheers and thanks!


#2

It could be EITHER.

MKVMerge 4.1.0 introduced Header Compression only on AUDIO tracks.    If the WD tries to play it, you’ll get Video but no Audio.

MKVMerge 4.2.0 and later has it on both AUDIO and VIDEO tracks.  In that case, it won’t work at all, and may have other bad results such as making the unit not work on GOOD files unless it’s reset.


#3

So I just talked to the support and they said its not even clear if the product will be supported anymore soon so theres no official yes there will be a new firmware…

Really? Im thinking to try the Seagate FAT+


#4

Don’t take this as gospel, but it’s what I can gather from reading and from my own tests.

WDTV Gen1 does not support DTS downmixing to stereo.  A DTS track will still play properly when connected to a DTS receiver through the optical connection, but no DTS audio is output over HDMI or the RCA stereo jacks.  In this case, it makes no difference what the file type is – anything with DTS audio is optical-out only – it’s not a Matroska problem.

This seems to be a licensing issue.  WD did not collect DTS licenses from any Gen1 purchases, so they could not add any DTS downmix support to any Gen1 firmware updates, back when they were still supporting the Gen1.  The official line was that the device did not carry the proper hardware, and yet PC media playing software seems to be able to handle DTS through a software-only solution and without any kind of licensed chipset (which makes me assume that licensing is what prevented DTS being added to any firmware upgrades and WD’s official answer about hardware.  Many posts around here insist that the Gen1 lacks the HARDWARE to decode DTS, and yet libdts and libdca are open-source SOFTWARE ONLY DTS decoders.  You can decode DTS without hardware.).

So, if you don’t have a receiver that you can connect to the optical output, you will not get output from any DTS audio track in any file you try to play.  The work-around is to re-encode and re-mux the file with something like Popcorn MKV Audio Converter.  You turn a 5.1 DTS track into a 5.1 AC3 track, and then the WDTV will output the audio over any and all of its outputs.

And then there’s the separate issue of Matroska compressed headers.  Since Gen2 devices support DTS, if there is no audio from a .mkv file on a Gen2 box, then this is most likely due to the file having header compression, as answered above.


#5

Thanks Roofguy.

I have a Gen2 device here and tested a mkv file with that header compression. So as already said I tried to play the file, the file was playing but NO sound.

As you assumed I also thought its that header compression thing and NOT a DTS issue.

Then I parallely bought the Seagate FAT+ and guess what?

The player is playing the sound of this file because it can handle DTS downmixing to play sound over HDMI.

That p**** me off a bit because the Seagate is such a **bleep**ty player. The menu is ■■■■, the picture is not as sharp as with the WD HD TV and I just love WD and the size of it.

So for me its not only the header compression thing, its also the DTS downmixing issue. And the Seagate is about 50 EUR here…

So Im thinking to give the Seagate back because remuxing takes 1 minute on my machine and it worked perfectly…just not that comfortable :frowning: