I can not listen DTS audio on MKV

hi everybody, sorry if it´s well known question but really i am rockie with WD TV LIVE HD an I  just installed it. I try to reproduce MKV file with DTS codec and video is ok but NO sound is listen. I have it conected to microcomponet LG with dolby digital capabilities throught an optical audio cable.

This occur when digital audio config option is selected but it sounds ok if i change WD config option to Stereo only.

AC3 sounds very good!.

What is this? its a problem? a receiver 's limitation?, WD shouldn’t convert it to play the same but with receiver limitation?.

Can you help me ? I´ll apreciate any advice!,


I’m glad I caught this; you posted in the wrong forum and I seldom visit in here.   This is the original WDTV forum, not the LIVE.

If you used MKVMERGE version 4.1, they enabled a “Feature” that kills audio in MKV files played on the WDTV Lives.

If this applies you you, re-run MKVMERGE and set the AUDIO Compression to NONE, and it should work.

Best way is new firmware.

Why WD will not make new firmware, where is header compression supported ?

I want not buy ne WDTV Live…

I love my WDTV !

This is only one problem I have.

The problem is not in MKVmerge, MATROSKA protocol officially support it (already 6 years).

Why does audio not play anymore since v4.1.0 (MP3, AC3, DTS audio tracks)?

The Matroska specificationsknow a feature called “header removal compression”. This allows a muxer to keep a certain number of bytes that are identical for each frame in the track headers removing them from the individual frames. This reduces the size of the tracks significantly without altering the content as a demuxer can add the bytes found in the track headers to each frame during demuxing.

Starting with v4.1.0 mkvmerge uses header removal compression for a couple of track types by default. These include AC3, DTS and MP3 audio tracks as well as Dirac and MPEG-4 part 2 (aka. XviD/DivX) video tracks. The user muxing a file may disable it by explicitely selecting ‘none’ as the compression scheme for such a track.

If your player has difficulties playing such files then it is a bug in that player or in the demuxer but not in mkvmerge. This feature has been part of the Matroska specification since more than six years, and there’s no excuse for refusing to add support for it.

The proper solution is to ask the vendor of your player to support this feature. A temporary solution is to re-mux such files turning off extra compression for all tracks.

Please… We need new firmware for all WD-TV Media Player

Yesssssssssssssssssss…  We need new firmware for all WD-TV  (GEN 1) Media Player !!!

cpacheco10 wrote:

Yesssssssssssssssssss…  We need new firmware for all WD-TV  (GEN 1) Media Player !!!

The WD TV Gen 1 player has been end-of-lifed.  There will be no further firmware updates for it.

that becomes its a disappointment for a great many customers

(from German by Babelfish)

WD don’t know if they releases a firmware for old and 2nd models would have happy customers that would buy more of their products and recommend them to friends, and the cycle goes on…  but all that i can see it’s a evil company looking for more and more easy money :s  BAD for Western Digital… !!

Lots of standalones and suchlike must implement header compression support. This is indeed a time of change, and whereas software players are easily patched, top boxes and other hardware equipment are a much bigger obstacle. However, I’m sure in a year or so, it will be de facto standard and this catch 21 phase will be even less than a memory.

Wow. Great customer service! 

Watching MKV files was the whole reason I bought the unit in the first place. Now it’s a paper weight. Thanks for taking my money and running WD.