Offline More Than a Week Due to Upgrade

I bought my MyCloud Home 2TB drive in 2018, I think, and ran into this problem once before in 2019, I think. While I understand the necessity to periodically update the firmware of the unit, I find it incredibly irresponsible to initiate a function that will take my unit offline for more than a week with no advance notice, no way to schedule the upgrade so it will have minimal impact on my workflow, and no progress meter to indicate how much longer it will be offline!

I assume nothing can be done but wait. (If anyone has any other suggested course of action, please let me know.) I am shocked that I seem to be the only one that finds this crazy. I have liked the unit and the price was reasonable, but after this, I will have to find something else because this is unacceptable.

Hi there! I have most probably the same issue… but for more than a week already. Did you simply let the device run on it´s own…? What was the front LED behaviour? Mine is not back yet unfortuantely.

Same here…but longer story

Had issues with Mycloud offline status with router not assigning IP to device

  1. Talked to support multiple times which identified that Full white led >>Dim led >>restart was most likely a disk failure…and I needed to pay $$$$ to recover data.
  2. Did not want pay and needed data so explored other routes. Followed instructions for reboot (10-15 reset button pressed whilst at the same time powering off on) to get to fast blinking.
  3. Waited a few minutes and turned on/off power with no effect…(ie back to point 1) BUT tried fast blinking status from point 2 for 15 hours and ONLY then switched on and of drive with 30s delay.
  4. BOOM it worked and after a few minutes device was alive and on Network but only for a couple of hours where suddenly it died again.
  5. Tried same procedure from step 2 and 3 again…and it worked again but now I have the same thing as you have with message such as the one in screenshot.

Mine is slow breathing (ie blinking slowly)

Came back on early this morning. Ordered a new NAS this morning about 2.5x the amount I paid for the MyCloud Home. Once I get it in a couple days, I will copy all the backup files to the new drive. I will keep the MyCloud Home as a backup, but will not use as my primary ever again.

Makes sense…glad you were able to recover data and I am just hoping to get to same result as you did (hopefully in less time). Unfortunately since my last post I know have a new message pop up " Database recovery" in web app and attached in the phone app

good luck

Thanks, out of curiosity did you ever go through that stage of database recovery? or do was message only upgrade in progress?

Ok, cool, lucky you. I´m still afraid of loosing all my data. But your device did also show “offline status” right?

only the upgrade in process message. Ironically, I just had hip replacement surgery two weeks ago and first realized I couldn’t access my MyCloud 2-3 days afterwards, so I am pretty sure my unit took around 10 days to “update”. I had around 1.75 of the 2TB in data used. I seem to remember when this happened to me last (in 2019?), it was the first time and I was much more panicked about losing data. I then think I may have forced a reboot (unplugging and plugging in) after several days since I had never in my 30+ years working with PCs had to wait longer than 10 hours for any sort of installation or upgrade. Fortunately, I didn’t lose info then, and since I knew it took a really long time the last time, I just let it do its thing, albeit bitching to WD and others along the way, this time.

yes, showed offline the whole time. Actually, it showed available online on the MyCloud website login before it showed available on my laptop. It went to a solid white bar night before last and I was afraid there was a problem so I used a paperclip to do a reboot and it went back to a white bar (with nothing showing access online or laptop). The next morning, I logged in (again, I had done this off and on for the last 10 days) online and was surprised to see it show my files. It was still showing offline through WD Discovery software on my laptop and I couldn’t see in File Explorer, so I initiated a reboot online, which it then did. Nothing changed, so I finally signed out of WD Discovery and logged back in. WD Discovery seemed to be locked up on the initial screen, showing an animation of files being sent to the drive, and kept running that animation without moving on for probably 10 minutes or more (never moved on) but I finally saw the files in File Explorer later in the morning yesterday. (By the way, the “Start and Sync” animation is still running now!! So, it is connected and I can see the files in File Explorer on my laptop, even though WD Discovery doesn’t appear to have fully loaded! Hope any of this helps. Good luck

Thank you all for trying to help but I was in touch with WD and they finally sent me this:

This is to inform you that your case was escalated to the concerned team along with the logs provided by you and after reviewing the logs, it seems to be errors with the disk on the device.
We would request you to take a backup of the data if the device is accessible but if the device is not accessible and if you wish to recover the data from the device, we would request to opt for 3rd Party Data Recovery options by following the link… - and of course - NOTE: According to the warranty policy, Western Digital does not provide any data recovery services or any reimbursement for it.

I will never ever buy a WD product again…obviously it was created by a defective firmware update…

Tengo el mismo problema con My Cloud Home Duo 6tb. Hace 68hs no puedo acceder a mis datos. WD soporte me dijo que la indexacion de archivos puede tardar hasta 5 días.
No fui informado del inicio de este proceso. No tuve posibilidad de programar esta tarea.
WD ha procedido muy mal con el cliente y debe reparar urgente esta situación. Es inaceptable este procedimiento.
WD no ha brindado información al usuario antes de iniciar la actualizacion.

Well it’s been now 7 days of that Device recovering message…and still no change. Any WD support people have an idea of what’s next and how long I should continue to wait?