NTP Incorrect time & date

I have a 1TB MBL updated to the newest FW: 02.10.09-124.  It does not display the correct date or time.  This problem existed in the previous FW, also.  NTP servers are fi.pool.ntp.org time.windows.com pool.ntp.org.  It is currently 34-hrs+XX mins behind real time.  I SSH’d into the device to check etc/ntp.conf.  It looks ok with the 3 servers listed.

Any ideas? How do I force it to check the time?

Try:  ntp1.npl.co.uk

Also, possibly a stupid question, is the time zone correctly set-up?

To add to Myron’s ideas if they don’t work:

From ssh, just issue the command “date -R”

Does it report the correct GMT offset?

Then, try the command:

ntpdate-debian

and post the output of that command.

Myron & Tony - thanks for the replies.  pls see below.

humm…the timezone is correct (Eastern Europe/Helsinki GMT +2)

MyBookLive:~# date -R

Mon, 21 Nov 2011 04:04:39 +0200

It doesn’t see the servers…

MyBookLive:~# ntpdate-debian

21 Nov 04:04:54 ntpdate[30008]: no servers can be used, exiting

I can turn off the NTP option and set time manually, but I’ve noticed if the NAS is shut down, the time effectively stops/pauses only to restart from the time it shut down, even if a few hours later.  So that’s not a good work-around.

Well, the fact that it says “no servers can be used” is telling.

Can you try running an NTP client on your desktop, pointing to the same servers?

ahem…my netmask address was missing.  That’ll do it!  All ok now.  thanks for the replies :slight_smile: