NTP Service fails!


I’m using a WD 6TB My Cloud Personal Cloud Storage.

Today is Friday, January 23rd, 2015.

Real clock should indicate 09:29:00 AM

My Time Zone is (GMT -05:00) Eastern Time (U.S. & Canada)

I have add a s a User Defined Time Server “time.apple.com” because I’m a Mac User.

The WD UI indicates Wednesday, April 16, 2014  7:32:10 PM

I can’t fix this.

I’ve tried with and without my User Defined Time Server, I also changed the language, I have My Cloud been restarted.

Nothing works.

Any Tips ?

Many thanks in advance for your advices and suggestions !

Hello and welcome to the community,

Take a look at this link. Hope it helps.


ninjacdm wrote:

I have add a s a User Defined Time Server “time.apple.com” because I’m a Mac User.

The fact that you’re a Mac user doesn’t really make any difference – try a different time server, like pool.ntp.org

Thank you very much for responding to my post.

Alas, nothing works…

Reboot, saving another time server, reset.

Is this a bug?


Not that I’ve seen.

Log in via SSH and try the command

ntpdate pool.ntp.org

And see what happens.

Thanks for your reply “TonyPh12345”!

Good news:

Problem solved by itself when I changed the Router configuration for my Internet connection.

Thus gave the NAS full access to the Internet and, by the way, to the NTP Service.

Everything is now A-OK.