No web interface after firmware update to 4.0

I recently updated my firmware to 4 and since then the web interface has stopped working. The myCloud turns on with a white blinking light and it can be pinged and if you open the web interface then it says ‘device initializing’. After that the light turns to solid blue and all the shares start working, the ssh works as well but the web interface just says ‘Failed to open page, server not responding’. I’ve tried reseting it using the button a few times and i’ve left it on for hours but no progress. The light stays solid blue, everything else works besides the web interface. Any ideas ?

Is this happening with different Internet Browsers as well?

Yes all internet browsers and from multiple computers. While the LED is white and blinking the web interface opens up but is really slow, same with the shared folders. Sometimes i can use the web interface for a few minutes even though its slow but as soon as the LED turns blue, the web interface just turns off. There is no loading of the web interface once the led is blue, it just instantly says site not available.

It sort of feels like the web interface just turns off somehow as soon as the HDD is fully on. Maybe there is a way to turn it back on or restart it using SSH ?

So I did ‘/etc/init.d/apache2 restart’ and i started getting the web interface again but it doesn’t look usable. There aren’t any options and you can’t update anything. Its just the UI that does nothing.

[quote=“FInale, post:1, topic:139233, full:true”]
I recently updated my firmware to 4 and since then the web interface has stopped working.[/quote]
Is this a My Cloud unit that you “unbricked” at some point in the past?

What firmware version were you upgrading from?

Ah yes I did unbrick it after it stopped appearing on network after being shutdown due to power fluctuation. I managed to recover my data and get the drive working again on version 3 i think. Is there a hope for the drive or did i cause some sort of permanent damage ?

You can read about my experiences with unbricking and the dashboard failing to display post v4.x firmware update in the following thread and what I did to fix it. Unfortunately to fix the GPT table, which worked in my case, it may (probably will) cause any data stored on the drive to be erased.

I don’t mind losing my data since i already backed it up safely. Thanks for the link, i’ll go through it! Just to confirm though I used my own WD Red drive that came with mycloud and did not change it.

Also did you happen to find 4TB WD image anywhere ? I can’t seem to find it.

See the other recent thread where someone was looking for the 4T image…

It that topic i only see 2tb and 3tb images and they mention expanding the main partition to maximum size to get full space. I couldn’t find the original 4tb image in that topic either.

See the last post in that link which has a link to another thread where at least one person talked about how they unbricked their 4T drive.

The guy in that topic says

This was the only solution that worked for me. I have the 4TB model and flashed it with the 2TB image. I was able to resize it with my Linux computer using fdisk, deleting the ext4 partition and creating that same partition number again using all the space available. The WD software automatically formatted the blank partition. So this was a quick fix that works well.

This worked for me as well, I did exactly that but it broke when i upgraded to latest firmware. Not sure what to do about that.

There may not be a 4T image, rather you might have to fix the GPT table like I had to do when unbricking a drive. I had to fix the GPT table (see Step 2 in the following directions) using Gdisk first before proceeding with unbrick process. It may or may not work for you.

How to unbrick, replace or restore original WD My Cloud single hard drive firmware:

These basic directions assume you have a 4GB or larger USB flash/pen drive, a computer with SATA connectors or some form of external SATA enclosure/docking station, basic knowledge of how to boot PC using a boot disc, basic knowledge of how to use Linux.

Note: Use and proceed at your own risk!!!

• Download original_v3.04.01-230.tar.gz to a flash drive:
• Used Ubuntu Live/Boot CD:
• To avoid damaging non WD My Cloud hard drives remove or disconnect them from the computer.
• Backup any data on your My Cloud as these directions may result in the erasure of all data on hard drive.  
• Insert USB Flash/Pen drive containing the file original_v3.04.01-230.tar.gz (or it's extracted contents) into PC before booting with Linux Live/Boot CD
• All terminal commands run from Root user or Sudo. For purposes of this guide Sudo was used.
• After booting with Live/Boot CD open terminal window by typing: 
[ctrl] + [alt] + [t]
Then type:
sudo apt-get update 
sudo apt-get install mdadm parted

To install new/used hard drive start with step 1. 
To repair existing bricked WD My Cloud hard drive start with step 13.

Note: Starting from step 1 will erase hard drive contents. If hard drive contains important data, backup hard drive before proceeding.

1. Find the My Cloud hard drive name (sda, sdb, sdd, sdc, sde, etc.) by typing:
sudo fdisk -l 
sudo parted -l

Note: For these basic directions "sdb" is used. 

2. If you get GPT errors running fdisk or parted then try the following command:
sudo gdisk /dev/sdb

Then type "o" then type "w" to fix GPT errors.

3. Run parted utility:
sudo parted /dev/sdb

4. Type "print" to see what partitions exist on hard drive.

5. If any partitions exist, remove each of them by typing "rm 1" (where 1 - number of partition)

6. Create new table:
mklabel gpt
mkpart primary 528M 2576M
mkpart primary 2576M 4624M
mkpart primary 16M 528M
mkpart primary 4828M -1M
mkpart primary 4624M 4724M
mkpart primary 4724M 4824M
mkpart primary 4824M 4826M
mkpart primary 4826M 4828M
set 1 raid on
set 2 raid on

Type "quit" to exit parted.

7. Format data partition:
sudo mkfs -t ext4 /dev/sdb4

8. Reboot computer, boot back to Linux Live CD. From command line run: 
sudo apt-get update 
sudo apt-get install mdadm parted.

9. Run sudo fdisk -l or sudo parted -l and note the drive names just incase the /dev/sd* location changed.

10. Create main RAID partition, type: 
sudo mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sdb1 /dev/sdb2

11. Wait for RAID creation to complete, type:
sudo watch cat /proc/mdstat 

Wait to 100%. Then type:
[ctrl] + [c] for close.

12. Stop auto-loaded raid, type: 
sudo mdadm --stop /dev/md0

If /dev/md0 not found type the following to find RAID mount point: 
sudo ls /dev 
sudo grep md

13. Start normal raid (must be /dev/md0), type: 
sudo mdadm -A /dev/md0 /dev/sdb1 /dev/sdb2

14. Using terminal window navigate to USB Flash/Pen drive location. Example: /media/ubuntu/<drive name> If the contents of file original_v3.04.01-230.tar.gz have not been previously extracted on the USB Flash/Pen drive, type:
sudo tar xvfz original_v3.04.01-230.tar.gz

15. Upload backup images to WD's hdd:
sudo dd if=kernel.img of=/dev/sdb5
sudo dd if=kernel.img of=/dev/sdb6
sudo dd if=config.img of=/dev/sdb7
sudo dd if=config.img of=/dev/sdb8
sudo dd if=rootfs.img of=/dev/md0

16. A Note: If for what ever reason the My Cloud fails to boot (white LED), or problems with upgrade to newer firmware failing/not working (ex. UI fails to load) try the following alternative step when unbricking:
sudo mdadm --stop /dev/md0

sudo dd if=kernel.img of=/dev/sdb5
sudo dd if=kernel.img of=/dev/sdb6
sudo dd if=config.img of=/dev/sdb7
sudo dd if=config.img of=/dev/sdb8
sudo dd if=rootfs.img of=/dev/sdb1
sudo dd if=rootfs.img of=/dev/sdb2

17. Shutdown PC from terminal window by typing: shutdown -p -H 0 Or use "Logout" from menu.

18. Disconnect hard drive from computer/external connector and connect to WD My Cloud circuit board. Then connect power to the My Cloud circuit board to turn on WD My Cloud. Boot process may take 5-10 min or longer. LED light should change from White to Blue.

Note: If the WD My Cloud fails to boot with either a solid white or red LED, then reattach hard drive to PC/docking station, reinsert USB Flash/Pen drive, boot back into Linux, go back to step 13, then proceed to step 16 to push the three "img" files to their respective partitions, shut down PC and try booting the hard drive again with the WD My Cloud circuit board. 

If the drive still fails to boot (white or red LED), the GPT entry probably needs to be repaired. If that is the case try step 2 above to rebuilt the GPT entry (will probably erase drive contents) and then perform the rest of the subsequent steps. If step 2 doesn't work then start from scratch at step 1. Backup any files if needed from sdb4 (the mountable ext4 partition containing the shares) prior to starting from step 1.

19. After WD My Cloud boots to Blue LED, access the Dashboard with web browser (http://wdmycloud/). Proceed through initial access screen then enable SSH on the Settings -> Network -> Network Services section. Often the capacity will be incorrectly listed, fix by selecting Quick Restore (or Quick Factory Restore) from the Settings -> Utilities section. The device will reboot and rebuild the system files.

20. After factory restore has been performed and WD My Cloud boots, restore any settings (like Static IP) as needed and update the firmware if needed. Be patient. If there was existing data on the hard drive it may take the WD My Cloud OS a long time to scan/catalog the files.

So I tried all of it and the result was exactly the same. It worked fine with previous firmware, I did a quick restore and it was showing the correct disk space and everything but as soon as I updated firmware the web UI just completely stopped working. Any suggestions ?

IIRC I had to do a system restore, the 40secs reset, after restoring the rootfs.

The apache logs probably will have some hints why the UI failed.

At the moment none other than try again. I followed those direction to the letter on two different drives that previously would not show the dashboard post upgrade to v4 firmware and it worked for both drives. In my case it appears fixing the GPT table in step 2 was the solution.

Do you just do step 2 and skip the rest or do you do all of the steps ? I’ve done all of the steps and it worked but no web interface after update. I’ll going to try again now.

For me I had to do steps 1 through 15, skipped 16 (which is an alternate way of doing step 15), then steps 17 through 20. For what ever reason those steps worked for me but there is no guarantee they’ll work for others.

One suggestion I’ve seen mentioned elsewhere is to format the entire drive as a single GPT EXT4 partition using Gparted, then erase that partition then perform the unbrick process. It appears folks have to do some variation of the various unbricking processes before they land on one that works for them. In my case it was the direction I posted above.

So I did all of it again including the format, same result. Then i only did step 16 (15 doesn’t work for me everytime) and now it started working again back from firmware version 3. Maybe I should look into the apache logs but I’m not exactly sure what to look for.