No remote. Help

I was given a WDTV LIve and I didn’t get a remote with it. I have ordered a remote, but won’t be here for a week or so.

I powered it on and had a message needing firmware, so I downloaded 1.06.43.

I was wondering if there is any way to control it withour the remote.

I have tried both my wireless keyboards and neither work (riitek N7, and Logitech MX3200), I have tried going to it’s ip address, but get the 404 page, I also tried telnet into it, but no luck.

Is there anything else I can do, or just have to wait till I get my remote I ordered?

If you have an android device or iOS device you can use the WD Remote app…

Yeah, I don’t. I have a blackberry, but no app for that yet. I did download the telnet remote, but that isn’t working.


Try a wireless keyboard (with USB dongle) when they work their really great.:smiley:

Keyboard shortcuts aren’t easy to work out tho.


Have you tried a USB keyboard?

I have tried a usb wireless, but I’ll try to borrow a wired one from work tomorrow and see if that works.


Yeah, I have a raspberry pi with XBMC and use the Rii N7 and works flawless, but that didn’t work for this for some reason.

Got the remote today, reflashed with the latest firmware and then works ok. Odd.