No desktop icon

I was going to run WD Smartware from my desktop icon, and when I did it said I neede an upgrade.

I ran the upgrade, and my desktop icon has disappeared.

I went into Windows---->Start---->Programs and selected the WD smartware program, expecting to see a “create desktop shortcut” option, but all I got was “Do you want to uninstall WD Smartware?”

How can I re-create a desktop shortcut?

Hi :slight_smile:

Try this method to place ANY program Shortcut on your Desktop …

Start > Programs > Western Digital > WD SmartWare

     - in this folder right click on “WDSmartWare.exe

     - select “Open File Location

       (if “Open File Location” is not an option then select Properties instead > Shortcut Tab > Open File Location Button)

     - in the folder that opens right click on “WDSmartWare.exe

     - select “Create Shortcut

     - in the dialog box that shows up click “Yes” to create a Shortcut on your Desktop

Hope this helps, if so then please click the “Accept as Solution” button below :slight_smile:

1 Like

Thanks - that was what I was trying to do, but no Wesren Digital appeared under “Programs”

I evenyually found WDsmart.exe by doing a search for WD*exe.

It was in an obscure folder called "Front Parlor

Once I found it, I created the shortcut, It is a different icon to what was there before, but I don’t mind that.

My gripe is still the same gripe I had with every software upgrade I ever had in the corporate sector - “All I know is, it used to work, and now it doesn’t”

They should be more honest and call every upgrade a downgrade.

I tried all the cures listed and none worked.

I then uninstalled the Smartware then re-installed it.

VOILA that worked but I will never again install an update.

I have had to have windows 8 reinstalled on my pc and it is know working fine again.

All other wd software has installed fdine. 

Can you please tell me how and why the ws smartware icon is not showing on my desk top after i have reinstalled the software.There were no reported errors with the software, it just the icon does not display on the desk top which is where it did on my previous installation.