No access to Dashboard, but pinging possible, ftp

Hello guys,

I have a WD My Cloud 4TB and I have massive problems with my drive.

For me its impossible to access the dashboard of my Drive. But I can access it via pinging, I can see the data via FTP, but I cannot connect to the dashvboard.

I tried with several pc’s or handhelds but the page is empty.

I use a UPC Samsung Horizon Router, I set the IP for the drive static in there. I tried to forwarding ports (don’t know if i did it right) and now I don’t know how to get any further…

If i switch off my router for a few minutes and then restart, then sometimes I am lucky and can access the dashboard but only for a short moment.
I believe its caused on incorrect settings in my router maybe…WD Support (sorry) ■■■■■ totally. They told me to send back the drive on my own costs and maybe get it back repaired. But I see the data via FTP so the drive isn’t corrupted.

Also to say: If I use another USB Harddrive on MyCloud the Drive crahes completely. I’m really really disappointed about the WD My Cloud and I saw many others have similar problems but no really way to get the problem solved.

Thank you so much if you can help me in this solution.


  1. Were there any modifications done?

  2. Have you enabled SSH access and can login via SSH? If it’s not enabled, try to enable it quickly when you mentioned you can access the Dashboard. It’s useful to debug what’s going on in the NAS.

  3. Have you tried the red button 4secs reset? Or may be the red button 40secs reset? Try not to reset if you have SSH access because IIRC the SSH will be disabled when doing the reset (4secs/40secs or even none sorry I can’t remember). Because if SSH gets disabled and your Dashboard has corrupted data, I can’t think of a way to solve this other than unbrick or RMA :frowning: