New Release - My Cloud Firmware Versions 2.31.163 (01/08/2019)

WD is happy to announce the release of My Cloud Firmware 2.31.163 for manual download at [ for the following My Cloud products.

· My Cloud
· My Cloud Mirror Gen2
· My Cloud EX2 Ultra
· My Cloud EX2100
· My Cloud EX4100
· My Cloud DL2100
· My Cloud DL4100
· My Cloud PR2100
· My Cloud PR4100

2.31.163 Release Notes

Security Fixes

  • Added brute force attack mitigation.
  • Removed non-production testing information.

Components Updated

  • Rsync – v3.0.

Other Bug Fixes

  • Added warnings when enabling remote dashboard.

2.31.149 release notes

Security Fixes

• Resolved multiple command injection vulnerabilities including CVE-2016-10108 and CVE 2016-10107.
• Resolved multiple cross site request forgery (CSRF) vulnerabilities.
• Resolved a Linux kernel Dirty Cow vulnerability (CVE-2016-5195).
• Resolved multiple denial-of-service vulnerabilities.
• Improved security by disabling SSH shadow information.
• Resolved a buffer overflow issue that could lead to unauthenticated access.
• Resolved a click-jacking vulnerability in the web interface.
• Resolved multiple security issues in the Webfile viewer on-device app.
• Improved the security of volume mount options.
• Resolved multiple security issues in the EULA onboarding flow.
• Resolved leakage of debug messages in the web interface.
• Improved credential handling for the remote MyCloud-to-MyCloud backup feature.
• Improved credential handling for upload-logs-to-support option.

Components Updated

• Apache -v2.4.34
• PHP -v5.4.45
• OpenSSH -v7.5p1
• OpenSSL -v1.0.1u
• libupnp -v1.6.25 (CVE-2012-5958)
• jQuery -v3.3.1 (CVE-2010-5312)

Other Bug Fixes

• Resolved high CPU utilization with ufraw-batch process.
• Improved remote host port handling

Hi, in the latest firmware update, when setting up new Remote Backup job (to replicate to remote WD NAS), it now hangs on the select “Destination Folder” screen showing a please wait screen, which never loads beyond that.

My existing Remote Backup jobs that were created prior to this software update remain working, however if I try to create a new one it fails on the select destination folder screen.

Can this please be investigated and firmware fixed as I rely on remote backups heavily, with this being the reason I purchased 4 of the PR2100’s.

You probably should open a support case. Posting issues in firmware release announcements are probably not the best thing to do. :slightly_smiling_face:

It actually is the best thing to do, since this isn’t an individual/isolated issue, this is a bug with the latest firmware release. So WD would need to fix the actual firmware release, as it impacts all users.

If I raised a support case, the support staff can only troubleshoot the issue, however since this is a fault in the actual firmware it’s not something a support staff member could resolve. This bug would need to be addressed by the development team.

Also to update, as a work around, I downgraded to V 2.30.193 which is the previous firmware release, this allowed me to setup the Remote Server recurring Backup job, once the job was setup, I was then able to upgrade back to this (latest) firmware version with the jobs still setup and working. This latest firmware has a bug where you cannot setup new remote server backup jobs, so this needs to be fixed.

1 Like

@joshobrien I’m unable to duplicate the issue, Please open a support case and attach the system logs from the Backup and Source PR4100 that you are having issues with so that we can investigate further.

  • Create remote backup on EX2 Ultra 2.31.149 to EX4100 2.31.149 = Creates and runs OK
  • Create remote backup on PR2100 2.31.149 to EX4100 2.31.149 = Creates and runs OK
  • Create remote backup on EX4100 2.31.149 to PR4100 2.31.149 = Creates and runs OK
1 Like

@joshobrien Belay my last and thanks for the reporting the issue.
ISSUE: The Destination Folder hangs if the Source Folder is empty and not selected first
WORKAROUND: Select the Source Folder and then the Destination Folder on 2.31.149

1 Like

I am using PR2100’s as both the local and remote servers. It just hangs when selecting the destination.

Good to see you’ve replicated. However from my tests it hangs at the select destination folder regardless of the source folder being full or empty. I am using both PR2100’s as the local and remote servers.

WORKAROUND: I downgraded the source PR2100 to the previous firmware version and then can create the backup job without issue. Created the backup job, once the recurring backup job is created, I then upgraded the source machine back to the latest firmware version. This then has the recurring backup job setup still and will continue to run the recurring job on the set schedule.

I am not sure that Sam meant the source folder being empty. I think he meant the source folder field is empty and not selected. The work around for the new FW would be to ensure you choose a source folder before selecting the destination folder.

@drlucky yeah I got that, I’m saying when I was testing it I tried both when the source field was empty or not and also tried with a source folder that was empty and full. It didn’t make a difference, the destination folder selection would just hang (as shown in my earlier screenshot).

I’ve recorded a video showing that with the source folder selected, it still hangs when selecting the destination folder, so that workaround doesn’t work. - Video:

The workaround I have done, is to downgrade the source machine to the previous firmware version, which allows me to create the recurring backup job without issue. I then upgrade the source machine back to the latest firmware version and the recurring backup job remains.

@joshobrien we’ve been able to replicate your exact issue on a PR2100. Thanks for reporting.

1 Like

Luckily some one of WD seems to have noticed this :slightly_smiling_face:.

From my experiences the chances are going nearly zero that a development team is reading / checking announcement threads (release and development teams are quite different, especially on such huge companies like WD) and thus reports like yours are getting lost.

Development teams are mostly working with bug trackers where support team members (thus the hint on raising a support case) are reporting bugs like you had posted here to.

I’ve replicated your issue exactly. And I have opened a support case as well. No response yet from WD. The one thing I noticed is it will work if you only choose one folder to backup. Otherwise, as I have to backup many folders, it hangs exactly as you indicate. Hopefully they will correct with a new firmware because I don’t have access to the previous firmware. They only post the latest online and I don’t usually download the firmware. I did this time, but the issue exists in this one… In any case, getting more and more frustrated with these PR 4100’s. I probably will spend my money on QNAP from now on. WD constantly has issues with firmware and “fixing” stuff.

FYI, when I click ‘Check for new firmware’, it says I’m on the latest version.
My last update was in October 2018 though so that’s seems incorrect.
I did a manual update now.

Hi, just to share: the same happens to me if I try opening the Time Machine options. I can’t choose any destination folder and can’t modify the previous status (Time machine off).
I also can no more see the back up disk in my Time Machine app on my Mac.
Any solution? Today I opened a support case… best regards n

I have the last firmware…

in the next firmware release would it be possible to bump up the sys fan please for the pr4100 from its default “fan rpm = 540” to something like the ex4100 i also have which is default “fan rpm = 610”

i noticed my ex4100 runs 3c colder across the wd reds than the pr4100 with same size wd reds in

its not a huge increase in speed and noise is same to my ear since its pretty quiet nas anyway and i prefer a cooler unit and drives

and to fix the lcd option “off” issue, on the pr4100 it only just dims the lcd while on the ex4100 it actually turns it off completely


it would be best to provide an option for each user to set the default speed.
the same for the LCD screen

This i definitely agree with if it’s possible to implement :grin:

If not a small increase in rpm to speeds like the ex4100 seems to default to would do me nicely… as I’d rather have the 3c cooler drives than 3c hotter even if it isn’t a huge difference :rofl:

@joshobrien, @WD_MCH I have exactly the same issue on my EX2 Ultra servers with 2.31.149.
I opened a support ticket. Awaiting WD’s reply.
Update: I downgraded the main NAS to 2.30.196 and was able to establish the backup job.
My conclusion:

  1. High five to WD for supporting downgrades.
  2. Walk of shame for releasing a firmware update that kills the main feature of this wonderful product.