New Release - My Cloud Firmware Versions 2.31.163 (01/08/2019)

WD is happy to announce the release of My Cloud Firmware 2.31.163 for manual download at [ for the following My Cloud products.

· My Cloud
· My Cloud Mirror Gen2
· My Cloud EX2 Ultra
· My Cloud EX2100
· My Cloud EX4100
· My Cloud DL2100
· My Cloud DL4100
· My Cloud PR2100
· My Cloud PR4100

2.31.163 Release Notes

Security Fixes

  • Added brute force attack mitigation.
  • Removed non-production testing information.

Components Updated

  • Rsync – v3.0.

Other Bug Fixes

  • Added warnings when enabling remote dashboard.

2.31.149 release notes

Security Fixes

• Resolved multiple command injection vulnerabilities including CVE-2016-10108 and CVE 2016-10107.
• Resolved multiple cross site request forgery (CSRF) vulnerabilities.
• Resolved a Linux kernel Dirty Cow vulnerability (CVE-2016-5195).
• Resolved multiple denial-of-service vulnerabilities.
• Improved security by disabling SSH shadow information.
• Resolved a buffer overflow issue that could lead to unauthenticated access.
• Resolved a click-jacking vulnerability in the web interface.
• Resolved multiple security issues in the Webfile viewer on-device app.
• Improved the security of volume mount options.
• Resolved multiple security issues in the EULA onboarding flow.
• Resolved leakage of debug messages in the web interface.
• Improved credential handling for the remote MyCloud-to-MyCloud backup feature.
• Improved credential handling for upload-logs-to-support option.

Components Updated

• Apache -v2.4.34
• PHP -v5.4.45
• OpenSSH -v7.5p1
• OpenSSL -v1.0.1u
• libupnp -v1.6.25 (CVE-2012-5958)
• jQuery -v3.3.1 (CVE-2010-5312)

Other Bug Fixes

• Resolved high CPU utilization with ufraw-batch process.
• Improved remote host port handling

It all installed fine, There are vulnerabilities dating back to 2010, 2012 and 2016 in this update and I have the question in my mind; “What other reported vulnerabilities are stil there to be fixed?” . Happy to see some of the core components like PHP and Apache being updated. Just curious why just for manual update?

Unfortunately the update has not fixed this particular issue.


Every time the NAS is restarted the Media Scan soon stops. This was occurring with the previous firmware.

It’s still working, but something that I don’t really need is not working and that’s the option to allow the NAS to hibernate and wake-up on a schedule. The scheduler will turn off the DL4100, but it will not power-up at the designated wake-up time.

It’s this feature I’m on about …

@Myron are you sating the power schedule is no longer working after you updated to firmware 2.31.149 ?

It has never worked at any firmware revision. It will shut down but does not wake up

@SBrown as @Gramps stated, it’s never worked. It would have been useful to hibernate the NAS during the night when it will not get used.

I wonder how many NAS owners have installed this update since it was released? (Just curious.)

E-mail notifications do not work. I have configured it correctly as I can get the NAS to send a test e-mail. Something that needs fixing.

This shutdown/startup feature has worked for me. I hear it shutdown at 10 PM and when I come home from work it is powered up just as I set it to do so. I will upgrade to the new firmware tonight and see if it still works for me.

I do off at say 10pm and on at 7am
does not wake up

I don’t know why mine works. I do have mine plugged into a UPS via the USB port if that has any effect.

My DL4100 showed that a new firmware update was available (on the LCD of the device) yesterday, so I updated it. Today, I now suddenly show 2 bad drives (appeared as 2x red status lights on the front of the unit). This just seems too odd to truly be 2 defective drives in one day, just doesn’t make sense. Anyone else see this? Hoping this is just a bug. I am ordering three new drives today as a knee-jerk reaction, but I cannot afford to lose my data. (Yes, I have a backup on a spare DL2100, but don’t want to revert to a backup if not necessary). I truly hope this is just a bug.

Thanks in advance!

After my installation of this version of the firmware (2.31.149) I could no longer access the folders and files with Windows Explorer in Windows 7. I could access the dashboard and I could access the unit with my iPhone app. My resolution was to downgrade to the previous firmware version, but I am not satisfied with this solution.

Has anyone else experienced this same problem and resolved it, other than downgrading like I did? If so, what was done to accomplish this?

Thank you.

Have you since shut-down the NAS, pull out and replace each drive individually and power-up the NAS? I’ve had it where for for one reason or another the SATA drive connectors where not making good contact so my modification was to make the rubber bungs behind the drive doors one millimetre higher.

Not yet, I bought 3 spare drives last night, just in case the 2 drives truly went sour - be here on Friday and now nervously chewing finger nails in the meantime. Once I have the drives in hand, I will do a power down and try the disconnect/reconnect on one drive first (not all at once and risk a total dump). I have a DL2100 which has run for years with no issues at all (and I am now holding on updating the firmware on it), so not sure why a reboot would suddenly show SMART failures on 2 drives at once, plus the all the SMART status links for each drive is showing the exact same data. Secondly, this is a RAID 5 volume. If two disks are truly bad, the volume should be down and unable to be read, yet it works perfectly. To me, this appears to be a firmware flaw, which is why I posted this up. Appreciate the input on the drive connector trick, was yours showing “bad” in the status when you had that happen?

Update, once I received the spare drives, I felt a lot more comfortable with making stabs at solving my dilemma. I did a full shutdown instead of the reboots like I did in the past, reseated the 2 drives that had the red status lights on them and then turned the unit back on. To my surprise, no drives showing a bad status, no red lights on the front panel, nothing. I don’t get it. I still think it’s a firmware issue. I just spent money on replacement drives and now I don’t need all of them. I guess I’m going to replace the 2x 3TB drives in my DL2100 (what I use to backup my DL4100) with 2x 6TB drives in RAID0 for 12TB space and do a new full system backup. :-\ This is frustrating and a costly mistake made by WD, on my wallet. I never had these kinds of issues with my DROBO, when a drive was marked as bad, if I pulled it and ran diags on it when installed in a desktop, it was truly a drive on its way out. This stinks. Kinda stings, in the area of trust at the moment. Should I be happy my issue is resolved, I am somewhat, but at a $500 hit to the pocket and wondering if this will come back.

glad you have no data loss. use the new drives for backups

This ended up being the permanent fix for mine.


Without those DIY spacers the drives will show as failed. Red status LEDs and lost data.