New Release - My Book Live Firmware Version 02.32.05-044 (9/5/12)

WD is happy to announce the latest firmware update for the My Book Live. For information about the firmware update, please check out the release notes.


Important update (9/20/12): WD released the My Book Live firmware patch 2.32.05-144, today. This release contains specific fixes for devices running firmware version 2.32.05-044


You can continue posting your experiences in this thread starting at the link below.

1 Like

I’ll be the first to take the plunge on my test MyBookLive… Wil report back

Upgrade successfully completed in under 10 minutes. I chose to download the file from the web and click upgrade from file in the MyBookLive UI. So far so good!

Anybody upgrading do me a favor and test your speeds with a good size 4-5 gig file to and from your MyBookLive before you do the upgrade and then again after. It may be bad memory on my part but I think my speeds are down about 4-5 MB/s after the upgrade.

I thought I used to get 40MB/s on 02.11.09-053

Now I get 35MB/s  02.32.05-044


With the new release, the Backup page is no more available on the dashboard. So how can I delete an unwanted backup?

TimeMachineBackup and SmartWare shares can now be seen on the Shares page. I can delete the whole share but not a single backup as before (with the previous release).

I’m going to test it over here, also.  transfer rates before and after. 

Thanks Bill!

Great, new firmware with so many resolved issues. It really took so long.

Hope this time WD tested it properly so that I can use my My Book Live finally.


Got a brand new My Book Live yesterday. After the firmware update I cannot make new shares (error code 33166)

or add new users: (error code 32102).

I also cannot access the Tools tab (#ui-tabs-2278) in the UI which makes it impossible for a factory reset. When i try to access it just says “please wait” forever…


Is there another way to reset the system? 

This is really annoying behavior from a 2 day old product.

Hope this can be solved…

Transfer rate before:   20 Mbyte / second averages.

Transfer rate after:  25 Mbyte / second averages.

Wow.  For me it’s faster;

But all I did was copy a 12 Gig MKV file and watch my system performance graph…  none too scientific…

Tony, glad to hear you got a nice bump in speed. My tests were none to scientific either as I just use an average from what Windows 7 shows on the transfer bar. I can say without a doubt that my 3TB Mybooklive that is still running 02.11.09-053 is 5-10 MB/sec faster on transfers using the same method and file

Just thought I give my upgrade experience.  Much like the past few upgrades which went smoothly.  After a few balky upgrades early on using the live online download of the update, I have exclusively downloaded the update manually and run it from Dashboard.

Status bar went to 5% at about 45 seconds, 10% at about 1 minute, then 50% at 3 minutes.  Got to 70% at about 4.5 minutes and 90% at 5.5 minutes.  At 6 minutes, 20 seconds it started to reboot.  At 7 minutes 40 seconds it started to initialize the device.  At 9 minutes it refreshed the dashboard screen and it was back up and running.

the HumpMan

After I updated I got about the same transfer rate at 30 MBs per second.  I did notice that the UI was much quicker.

Update done and succesful … :smileyvery-happy:

Just an FYI - We updated the Samba stack to SMB2. THis was done in preparation for the upcoming Windows 8 Launch. There were requirements to support features of Windows 8 that required the upgrade to SMB2. This may be some of the reason why you are seeing performance gains.

@WDTony Could it also account for some performance loss?
@Bill_S Yes I did notice the UI was quicker as well :slight_smile:

We have not seen any performance loss in our testing, so maybe there is something else going on - maybe the server is busy with something else?

First graph is 1gb file from computer to 3TB MBL on 02.11.09-053

Second graph is same file from computer to 1TB MBL on 02.32.05-044

Nothing running in the background on the 1TB MBL…All media features turned off… Both MBL connected to the same router… Tried new cat5e cable same results

Might rollback my 1TB MBL to 02.11.09-053 later tonight to see if it makes a difference

Upgrade seemed to go smoothly, but the UI timed-out waiting for my 2 TB MBL to come back up.  I waited 15 minutes, still nothing.  FInally unplugged ethernet, waited, plugged it back in.  I now seem to have an “Initializing” on my UI.  The drive “feels” like it is reformatting, which will be kind of disappointing because I have a lot of data on it that took a long time to put there…

Anybody have any suggestions for how long I should wait for “Initializing Device, please wait” to complete?