New My Book LIve

I have a new 3 TB My Book Live (just purchased).  I upgraded the firmware to the latest version.

I am unable to do certain things.  when I use the web interface, and click the shars button I get: “30005  - Unable to retrieve data.  Make sure there are no network connectivity issues and try again.”

or when I try to enable remote access, I get, “Error 31505 - The device status could not be updated due to an communication or internal software error.”

Connection Status is Failed - Cannot establish remote access connection.  Make sure you are connected to the internet.  

Obviously I am connected or I could not draft this message.

Thanks for your help.

The fact that you are connected to the internet doesn’t mean that the MBL itself is. Did you check your router in case the MBL has an IP address conflict, doesn’t have proper network settings, has been denied remote connections by the firewall/internet security or has no ports mapped for remote access?

Thing is, bu default the MBL get’s it’s IP from the router’s DHCP server (unless the IP settings are manually set) and refarding remote access (not the FTP service) if the router is not port forwarding from WAN to LAN then the MBL set’s up a relayed connection.

I have the same issue - all was working fine until I just downloaded the latest firmware, now I am getting the same error when I click on users or shares.  Was there a solution found to this?

product support just suggested I back all my data up and do a reset to default settings!  Does anyone have any better suggestions?

With your MBL being new and assuming you’ve not put a lot of data on it…   Yes. Back-up your data and do a factory restore.

I already have moved 1.5TB of data off external hard drives I had and then reformatted them for use on my PVR which requried them to be FAT, not NTFS.  Backup and restore is not an option I am looking for.

I’m thinking of going back to shops buying the seagate drive copying data to that and returning the WD if this is the best option support can come up with.

This isn’t a support forum- We are other users of the device just like you. If you need support, there is an email form.

That being said…

This is one of the most reliable drives on the market… far more so than any Seagate i’ve ever come across…not to tell you what to do…but thats not a choice I would make!

Do you have any kind of backup at all for this data? You should NEVER keep all your data in 1 place, regardless of who’s drive you use… hard drives are mechanical devices and subject to failure over time (3-5 year lifespans on average). If you don’t have a backup, your risking everything you have on there.

Regarding your issue, it sounds more like a router issue than a drive issue. Try doing a full reboot of your router, checking for any conflicts, etc. – Does your router have a firewall? If so try (VERY TEMPORARILY) putting the MBL in a DMZ or turning off the firewall- see if you are able to access it at that point. Same goes for any other network firewall.

emailjimmy wrote:

I already have moved 1.5TB of data off external hard drives I had and then reformatted them for use on my PVR which requried them to be FAT, not NTFS.  Backup and restore is not an option I am looking for.

 

I’m thinking of going back to shops buying the seagate drive copying data to that and returning the WD if this is the best option support can come up with.

Are you familiar with SSH? If so, move any and all data stored on the drive to the public share and run the following command which will perform a factory restore without deleting data:

/usr/local/sbin/factoryRestore.sh noreformat

Use at your own risk.

2 Likes

Hold on a second.  So…  Performing a Full factory restore or a Quick factory restore from the Dashboatrd UI will wipe /DataVolume but using . . .

/usr/local/sbin/factoryRestore.sh noreformat

. . . will perform a full factory restore BUT will NOT reformat /DataVolume leaving all the user data absolutely and completely 100% intact and in-place?


Myron wrote:

Hold on a second.  So…  Performing a Full factory restore or a Quick factory restore from the Dashboatrd UI will wipe /DataVolume but using . . .

 

/usr/local/sbin/factoryRestore.sh noreformat

 

. . . will perform a full factory restore BUT will NOT reformat /DataVolume leaving all the user data absolutely and completely 100% intact and in-place?


What he said… :robotsurprised:

Can we get an option for this in the menus?

How annoying and disappointing is that for all the people who have lost loads because of a normal factory restore.

Thing is, I’ve seen this “noformat” option but didn’t think much of it. Thought it was just a erroneous comment left in my accident.   :neutral_face:

I am having the exact same issue.  You described it perfectly.   My MBL is updated with the latest firmware as of 12/19/2011 (I’m not in front of it right now, so can’t look at the exact version). 

I am running Windows 7 and don’t have any firewalls enabled.   My drive is on an internal network with manual network settings.   The settings are set the same as my other machines (with the exception of IP address of course) that can access the internet just fine.  I have tried DHCP as well.  Nothing seems to work.  Still can’t get to shares or users w/o an error.

Have you been able to find a workaround for this yet?  Did you try the restore to factory defaults?  If so, did it work?

Thanks

I had the same issue as described above. Followed the advice of the folks here to reset to factory default without reformatting. and it works! Users and Shares tab are no longer throwing error.

The steps are the following:

  1. enable ssh on your WD MBL by following steps here:  http://community.wdc.com/t5/My-Book-Live/Telnet-or-ssh-my-book-live/td-p/87065

MyBookLiveUser wrote:

Load the Mybook UI go Settings > Utilities > Import / Export Current Configuration

 

Export the current configuration, open the file in notepad (Wordpad screws the formatting so be careful), find the bit that says: ssh_enable=“disabled”, change to ssh_enable=“enabled”, save the file

 

Now back in the Mybook UI go Settings > Utilities > Import / Export Current Configuration and import the file you have just saved.  The Mybook reboots and hey presto SSH is enabled.

 

On mine the login was root / welc0me  (that is welcome with a zero instead of an oh).

  1. If you use Windows, download putty: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

Run it and put in the ip address of the MBL. 
Password is:welc0me

  1. run /usr/local/sbin/factoryRestore.sh noreformat

reboot.

  1.  voila!
1 Like

Or just enable SSH by firstly logging into the Dashbourd UI then using the URL:
http://MyBookLive.local/UI/ssh

Enables and disables SSH without a the NAS needing a reboot.

If you’ve changed the name of you NAS then substitute MyBookLive for the name of your NAS.

How does one enter this command line in Terminal? I’m having the same trouble as described above!

I know how to do this on Wiindows.  Not sure how to start a terminal sesion on a Apple MAC.

PuTTY.jpg

  • Login to the Linux shell using the user-name and password revealed to you when you enabled SSH.

You should now be at the Linux command prompt where (at your own risk) issue commands and invoke scripts and programs.

From what I’ve read elsewhere, move everything you wish to keep into the Public folder before invoking a non-destructive factory restore.

1 Like

Thanks for the response (I’ve been on holidays) - I’m just backing up my critical files and then I’ll give it a go.

Always good to keep a recent back-up of stuff you may wish to keep.  Like tonight I’ll turn on my other NAS that’s my back-up, start the Safepoint back-up task and go to bed.  :smiley:

Thanks!

the restore worked (and files are intact).

better support here than the telephone support provided by WD.